Unwanted offset when cutting/engraving

So im triying to make multiple copies of this same design, but the outer circle increasingly offsets on x axis (text is on a different process).
Im using a chinese laser (almost new, belts are fine) with ruida controller(6442S-B), 20mm/sec speed which is pretty slow, and either using the pattern feature or manual copy results on the same issue ): . Seems it happens only when i do 6 or more copies.
Looking for some help in laser facebook community I’ve actually found a way to bypass this issue (by using the “Order by Group” in optimization settings) but with now having the offset issue affecting in between the groups, which results in a not so clean cut )= (SECOND PICTURE).
Could anyone reproduce this issue so i can know if this is a machine or Lightburn problem?.

I read someone had a similar issue on a different topic and it seems is a Lightburn issue.

Please Help ):


Is the word ‘NARDA’ written along the X axis?

Are you filling the letters with horizontal passes or are you using Flood-fill?

The second photo appears to show some kind of lost motion assuming that everthing was lined up on the work area in LightBurn.
IMG_1865 NARVA Cropped

Check for physical looseness in the x-axis hardware (belt, pulleys, set screws, bearings.

Hi, thank you for responding, I’ve actually solved it a few days ago.
“Narda” was fill and “Industrial” was flood-fill, and yes, it was done in the X axis. Nevertheless the problem was a not so obvious one, I was able to fix it by setting “PWM Rising Edge Valid” to FALSE in the ruida settings. I guess it happened because the stepper was moving on the pulse rise which caused unnecessary extra movement, though mostly visible on large symmetric patterns.
Btw, this video on mechanical backlash correction also helped and worth watching, but did not make the major effect for fixing this issue.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.