Update Overlay weirdness

The Camera Control tool shows WN.RCamera8M selected. A camera frame is displayed, but is generally a ‘frozen’ frame. If I wave my hand below the camera, the Camera Control tool goes ‘live’ and displays my moving hand, but when I withdraw my hand, the view ‘freezes’ with a movement-blur image of my withdrawing hand. If I put my hand back into the camera’s field of vision, it ‘sees’ it again and the image in the Camera Control tool displays the moving image.

If I click “Update Overlay” while the image is frozen, the overlay isn’t updated.

If I then go stick my hand in front of the camera lens again, both the Camera Control tool and the overlay are updated with a still image of my blurry hand. Similarly, if I move the lid of my machine (so the camera view changes), then the Camera Control tool updates with the moving image. The overlay still shows the blurry back of my hand.

While the laser is operating, the Camera Control tool continuously displays a smooth video of the tool in motion, the smoke, etc.

Once the tool is at rest, the image displayed in Camera Control is again ‘frozen’ and Update Overlay doesn’t display the overlay unless/until the camera’s field of vision substantially changes.

It appears (maybe?) LightBurn v1.3.01 is ignoring the camera unless movement triggers an update to the Camera Contol tool and the overlay display.

My laser: OmTech MF2028-100w
My controller/ firmware: Ruida
My computer: ASUS 32gb Intel(R) Core™ i7-8700K CPU @ 3.70GHz 3.70 GHz runing Win10 Pro v22H2
My LightBurn: version 1.3.01
My camera: Lightburn 8MP Camera (4K-N) 75 degree properly mounted in the lid so it sees the bed while the lid is open and fixed in place with a stick
I did successfully calibrate the lens and camera alignment (under Laser Tools)

I recall another user having a similar camera issue. I want to say it was narrowed down to electro-magnetic interference or possibly a bad cable.

You may want to try shielding the camera and cable to see if that helps. If it does, then coming up with a cleaner long term solution.

The other thing to check possibly is to plug into a USB3 port to see if that behaves better.

If you’re connected through a hub or anything try eliminating that to see if that improves the situation.

@berainlb - thank you for the reply, but I don’t believe that the issue has anything to do with electro-magnetic interference, a bad cable, or the 4-port extender I’m using over 50’ of CAT6 and here’s why:

  1. A 12 x 12 inch cherry wood work piece is roughly centered on the bed.

  2. LightBurn is running with a cutting file open and camera “none” is selected.

  3. Windows’ Camera app displays perfect hi-def video from the camera, regardless whether the laser is in motion. Waving my hand in front of the camera displays my waving hand smoothly in Windows’ Camera app just as you’d expect.

  4. Windows’ Camera app is closed and the LightBurn camera is selected. Lightburn USUALLY does not display any image and clicking “Update Overlay” doesn’t update the main screen with the overlay.

  5. Once the laser is put in motion by clicking ‘Frame’ and the laser head has moved about six inches toward the workpiece, the image appears in the Camera Control window and, if Update Overlay was clicked in (4) above, the overlay appears in the main screen.

  6. The Camera Control video display ‘hangs’ at roughly the same position as the laser head travels the frame, then predictably resumes display at a later position for a bit, then ‘hangs’ again and resumes again later. This is repeatable with this size of block. Clicking Update Overlay during framing does update the overlay only while the camera control window is moving. If the video display is hung when Update Overlay is clicked, the overlay will appear as soon as the video begins ‘moving’ again. The effect is like the camera cuts out for a while, then back off and back on as the laser moves through the frame.

  7. The 12 x 12 inch cherry piece is removed and a larger birch workpiece about 17 x 24 inches is placed in about the center of the bed.

  8. The Camera Control video usually displays a still image of my hands on the larger workpiece as I set it into place. Clicking Update Overlay doesn’t update the overlay.

  9. Clicking Frame the Camera Control video starts when the laser head is 4 or 5 inches from home and displays continuously and smoothly from start to finish. The overlay (from clicking Update Overlay in step (8)) is displayed as soon as the video begins moving and shows the laser head in motion 4 or 5 inches from home.

  10. I have replaced the smaller workpiece (12 x 12 inches) and added the webcam I use for Zoom to the 4-port USB extender at the laser and now I select it in Camera Control, it immediately displays the view from the camera (upside down because I have it hanging upside down from the laser handle). When I click Update Overlay, the overlay is updated. When I click Frame, the overlay is updated. The Camera Control video is smooth and continuous throughout the frame operation. Clicking Update Overlay after frame movement is complete immediately updates the window. The view from this webcam is quite different from the LightBurn camera, but in earlier tests, I DID notice that the display from the webcam hung in places just as the LightBurn camera did.

  11. Now I select the LightBurn camera again (WN.RCamera8M). The Camera Control window still shows the frame from the webcam in (10) and clicking Update Overlay still displays the view from the webcam in (10).

  12. I click Frame and the Camera Control video begins as the laser head is about 6 inches from home, the video plays and hangs just as in (6).

I’m kinda thinking that this is a software issue with LightBurn and NOT a hardware problem with camera(s), cabling, extender, etc. I’ve run a dozen 2-hour jobs while the LightBurn camera smoothly displays the workpiece and smoke and the jobs cut without a hitch. Maybe there’s some motion detection happening in the video capture?

What do you think?

I can document this with video if my explanation is unclear - let me know if that’d help?

I don’t believe this is the case and is why it reminded me of the other post. They had the same behavior where motion was required to get the camera to work. This is what led to the notion that the issue could be related to electro-magnetic interference since the presence of a hand could potentially change that.

Have you tried plugging the camera directly into your computer and checking the behavior?

Normally the view in Camera Control window would be a continuous live feed as you describe for your Zoom camera. The overlay is static. One thing that struck me as odd is that you say that the overlay updated when framed. That shouldn’t happen as far as I’m aware. The overlay should only ever update with the “Capture Overlay” button.

The other thing that’s odd is the name of your camera “WN.RCamera8M”. Normally this would show as “LightBurn Camera” or something similar. I’m going from memory. I assume this means that the extender solution is likely processing or altering the ID information for the camera.

I would say first order of business is to check the behavior with the camera plugged in directly and then determine deviance in behavior from that point.

The other thing you could experiment with is changing the “Camera Capture System” in Settings. If you’re on Custom try switching to Default and vice versa.

1 Like

@berainlb - thanks. The OMTech is 25 or 30 feet from my desktop computer and neither can be easily moved in order to connect the camera directly, but I suppose I could install LightBurn on a laptop in order to carry out your ‘first order of business.’

Before I experiment with a more portable computer that I can set up at the OMTech, I’ll try changing the Camera Capture System in Settings from Custom to Default and I’ll let you know… Baby steps.

Thanks again!

@berainlb - Progress! Changing the camera capture system in Settings from Custom to Default did NOT change the name of the camera (still WN.RCamera8M) and the extender isn’t likely altering the ID information for the camera since LightBurn correctly recognizes my webcam when plugged into the same extender). BUT - the Camera Control now immediately brings up the video and Update Overlay immediately brings up the overlay AND the Camera Control video plays smoothly and without break while the small workpiece is on the bed. I can see from the overlay that I now must recalibrate the camera lens and alignment.

Again - I’ll let you know how it works out - much appreciated!

@berainlb - SUCCESS! Changing the “Camera Capture System” in Settings from Custom to Default solved this weirdness.

I had never edited any of the settings, but when I looked, the Camera Capture System was set to “Custom Camera System” - as soon as I changed it to “Default Capture System” both the Camera Control and Update Overlay instantly worked perfectly. I’ve recalibrated and actual cutting vs overlay is within about 0.1 inches. I’m happy!

Thank you again for your very prompt responses and for suggesting changing the setting of the Camera Capture System.

1 Like

Glad that worked. Odd symptoms, however.

1 Like