Updated Software Now Movements Are Off

Windows 10, Neje e80 Max 4 with the extension kit.

Have tried everything I can think of for the last few hours. Made a video to explain the issue I’m having better. https://www.youtube.com/shorts/mQ3s3ll13fU

$$

$0=10

$1=255

$2=0

$3=0

$4=0

$5=0

$6=0

$10=3

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=1

$23=1

$24=250.000

$25=1000.000

$26=250

$27=1.000

$30=1000

$31=0

$32=1

$40=0.200

$41=10

$42=10

$43=0

$100=80.000

$101=80.000

$102=800.000

$103=8.889

$110=24000.000

$111=15000.000

$112=1200.000

$113=21600.000

$120=400.000

$121=250.000

$122=20.000

$123=250.000

$130=750.000

$131=460.000

$132=45.000

$133=360.000

ok

Hopefully something simple, I remember something similar was going on when I first put it together but I think I just had to change the orientation or something and nothing seems to be helping with this.

Any help or insight will be greatly appreciated.

Thanks,

Matt

Hi!

With exception of you Z motor steps per mm which seem HUGE at 800, the jog speeds you are experiencing are set on MOVE panel, speed
image

It’s not the speed that’s wrong. The machine will home but then go to start from the middle of frame. That’s what I meant by the movement, you can see in the video.

The X position reads as 0 when it’s homed but the Y reads as 460 when it’s homed, I think that’s where my issue lies.

It has the y zeroed in roughly the center of the machine.

Type the following
$# press enter
post output please?

Also Edit > Device settings can you take a screenshot?

Lastly, what Start From are you using?
Absolute coordinates?

$#

[G54:0.000,0.000,0.000,0.000]

[G55:0.000,0.000,0.000,0.000]

[G56:0.000,0.000,0.000,0.000]

[G57:0.000,0.000,0.000,0.000]

[G58:0.000,0.000,0.000,0.000]

[G59:0.000,0.000,0.000,0.000]

[G28:0.000,0.000,0.000,0.000]

[G30:0.000,0.000,0.000,0.000]

[G92:0.000,0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000,0.000:0]

ok

I have messed around with all of the start from locations, right now it’s set on “current position”

No offsets, all seems normal

Could you please instead of Start, click Save Gcode, and upload it here (might need to change the extension from NC to txt)

Also a full screenshot of lightburn with a project - that fails - open please-

I drew a couple boxes, hit save gcode and this is what it spit out.

; LightBurn 1.6.01
; GRBL device profile, current position
; Bounds: X0 Y0 to X648 Y462
G00 G17 G40 G21 G54
G91
M4
; Cut @ 100 mm/sec, 20% power
M8
G0 X368Y82
; Layer C00
G1 X-275S200F6000
G1 Y197
G1 X275
G1 Y-197
G0 X280Y-82
G1 X-648
G1 Y462
G1 X648
G1 Y-462
M9
G1 S0
M5
; return to starting pos
G0 X-648Y0
M2

Is there a way to tell it that the Y is in a different position. For instance when it tells me while it’s homed that the Y is at 460, can I tell it that 460 is actually the 0 position?

In this case, and this a very neje thing, your TOP left is home

But your X0 Y0 should still be front left.

Easy way to test it.
Home
Go to move > get position
Should be… X0 Y750

If you set X0 Y0 on the little boxes and click go it should go front left

If you can take a full picture of your machines too so I can visualize the full frame would help


Are the axis correct?
image

Yes, I mean they move in correlation with the X,Y in lightburn anyway.

It’s working fine right now, been sitting in silence staring at it trying to figure out what I did to make it work. Only thing I can think of is let it move into the center like it was doing and then I changed the origin in device settings. I did that multiple times for hours yesterday though.

Wish I could say exactly what I did to help someone else.

I really appreciate your time and support.

At times, we should not question the Laser Gods and just accept it! :smiley:

Jokes aside!
Do keep us posted.
Where did you change the origin to though, it was set to back/left right?

Your video seemed fairly normal. You started from left rear and used pointer to go down to bottom left. The pointer doesn’t do increments, it moves as fast as you have set the speed to the coordinates you drop the pointer.

Back left or top left, not at home right now so couldn’t say 100% but one of those, i’m thinking top left. I then changed it back to the exact movement or coordinates (whichever that setting under the move tab is). It was framing the wrong work area before I changed it back to that.