Updating !.2.02 to 1.4.00 7Z Linux

As I understand it the search for updates does not work. I therefore attempted to delete 1.2.02 and install 1.4.00 7Z. All appears ok as I created a new Folder and extracted updated version to this. When I go into the folder and attempt to run the program using AppRun I am led to an Applications folder where I can click on the Lightburn Logo which starts lightburn however not the updated version. How do I overcome?
I have other problems with framing but thought this would be a good start.
Any assistance much appreciated

If you fill out your profile, we might be able to be of more assistance. I run Linux, some run Macs and still others have Windows based machines. From the title I assume some variation of Linux… I run Ubuntu.

You profile allows us to see what kind of machine and pc/os you are using.

Just a heads up…


I have mine in ~/ or my home directory …

When I upgrade, I rename the original Lightburn directory to something like Lightburn-x. Then extract the new version into my root directory.

Since you don’t modify/delete the LightBurn.desktop file, it should just run when you click on the icon wherever you have it…

I have two icons and two desktop files… One is beta the other is release.

Make sense?

:smile_cat:

Thanks will update prifile. Will rename Directory

How do I update my prifile?

Deleted and created a new folder with different name in Desktop. No difference.
\ps \have logged in

What distro+release of Linux are you running?

Linux Mint 20.3 Una

ubuntu-12.04.4-desktop-amd64

From a terminal, try lsb_release to get a nice output of the machines os software…


jack@Kilo:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy
jack@Kilo:~$


It also formats nicely for posting… this is just copied and pasted from the line starting with Distributor…

Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy

Neat huh?

:smile_cat:

Well I have managed to update to 1.04 which has not resolved my framing problem I will post a new topic

Have even sorted my framing problem. “rotary On”. grrrrrrr

1 Like

Glad you got it solved! Note that Linux Mint isn’t an officially supported Linux distro (Ubuntu 20.04LTS is our only one at the moment) - there can be issues with other releases. But, sounds like Rotary was the main culprit here.

Colin, I thank you for your assistance and advice. I have LB on three desktops. I have an iMac which runs nothing as I do not rate it as too many hang ups. I have two old HP machines that I changed to SSHD one works ok on Mint and I will leave for the time being. The second HP runs a small laser engraver. self made, giving framing problems etc and I will convert this to Ubuntu as suggested. I may well return with other problems. I am a 77 year old apprentice .enjoying all these challenges

1 Like

Just quick update, total disaster. On one machine I managed to get Ubuntu loaded but unable to resolve resolution problems. On second machine I created a partition as I wished to retain Mint. Ubuntu has loaded and resolution ok but I cannot connect with "“Port failed to open - already in use?” Whatever i do cant resolve. In addition I may have erred with my password for Mint, as cannot load. Spent a bit if time with my iMac and it has run ok . Spent a lot of time with Ubuntu, achieving not a lot. If I coukd resolve the fail to connect I would be happy.

Edit Finally resolve the port failure by trying other USB ports…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.