Upgrade to 1.2.01 has huge problems

Sorry I didn’t respond sooner on this. So The one down and right of the 3 offset fish was just changing the passes from 3 to 1. It is still set to fill shapes individually, and I still had it at 300 speed.It still didn’t complete the splash of water correctly If you compare it to thedarker one just up and to the right of that one, I did 200 speed to darken it more. I also had it set to 1 pass, but I changed it to fill all shapes at once.

If you compare the two fish, you will notice that the lighter one does not look like it should. It almost looks a bit taller than the other one which gives it that stretched look. The dark one is more correct and true to the original pic.

This is what the fish should look like:
fish_splash

Ok, there is definitely something fishy going on here!..and it seems to occur when the shapes are set to fill individually.

Using “Fill shapes individually” does result in a lot of extra rapid movement, which I suspect is a factor. I understand you have had this laser for a couple of months now? - have you noticed other situations of unexpected drift or deviation in position, or movement that is loud/jerky?

Dan, could you go to Edit>Machine settings and take a screenshot of your x and y axis settings (from the Vendor area) eg.

And to be thorough, if you could also save the controller settings to a file and upload here that would be great.

OK, so here are the X and Y machine settings.

And here is the controller settings. I assumed you meant to use the “Save to file” button in machine settings to save this.
controller_settings_8-2-22.lbset (12.7 KB)

Thanks, a few observations…

-Your machine settings above show PWM Rising Edge Valid as True for X, yet False for Y, since your issues are mostly in X, you could try setting this to false to match Y. (Change and “Write”).

If that makes no difference, here are some more speculative thoughts;

-Your step length of around 30um is roughly 4x larger than mine (7.8um). If your drive ratios are similar, I’m guessing your stepper drivers are set to 1000 (micro)steps/rev at the dip switches? My X and Y are set to 4000. This is not necessarily a problem, only mentioning because another Omtech (2028-80) customer @dbtoutfit had resonance and drifting problems (specifically relating to traversing and engraving) which were eliminated by increasing the micro-step resolution to 4000, along with some reductions in speed/accelerations.

-Your “Return Position” in the lbset file is set to “Origin”, rather than what I typically see set to “Absolute Origin” (at least on Thunder Laser systems). Theoretically “Origin” should be fine and presumably should return the head to user origin after the job. I cant see any difference between these settings on my system or reproduce your error - but… the large and consistent offsets in your first photo between each pass does suggest a “wandering origin” relative to individual part size.