Upgrade to 1.2.01 has huge problems

So I am using Lightburn with my OMTech MF1220-50 engraver. I have been working on a layered project which up until today has been going pretty good. I turned on my laptop and when I opened Lightburn which told me that there was a new version out there, 1.2.01. I downloaded and installed it. I was going to do another cutout layer of my project which had some engraving on it. When I started the first part which is the engrave for that, I was getting a tripple image. (sorry, not sure how to post pics in here so I put them on my website and am posting the links to them). The first picture link is the screenshot of what the layer should be. The red is the engraving for the layer and the black is the cut. Lightburn screenshot image. This is a picture is how it came out on my bed. I stopped it before it got too far, but you can clearly see it was doing a tripple image. The workpiece on the laser bed.

Is there added permissions need to post pictures in a topic?

To post images here, you can use drag and drop, or use the OS copy and paste, or hit the Upload button. All should work in-line.


Additionally, post the LightBurn file so folks can review. :slight_smile:

Attached is the lightburn file. I should add that this is 5 different layers. Some are just cut layers and some have engraving and a cut. I did layer 2,3,4 and 5 on an older version of Lightburn and didn’t have any trouble. Also, I created the file on my desktop machine which is a linux PC, but the computer that I run the jobs from is a Windows laptop. That shouldn’t make a difference I would think since layers 2, 3, 4 and 5 went just fine.

Wisconsin_layered_plaque.lbrn (3.0 MB)

Please also post the GCode used when you observe this triple image (append .txt to the filename to allow posting).

This is using a ruida controller. There is no g-code. Besides even on my diode laser I don’t save the gcode first. I send it directly from lightburn to the machine. Same thing with my CO2 using the ruida controller.

Ah, thanks for that clarity. I was working from what you tell us and missed the mention of the OMTech MF1220-50 engraver. :wink:

Sorry, I forgot to update that when I got my CO2 a couple months ago. I will go and do that now.

So am I the only one having this issue?

How does it do if you set the red layer to bi-directional fill? Is there a reason you’re doing 3 passes?

To tell you the truth I din’t see that it was set to 3 passes. Not sure how that got set to 3. The odd thing is that is the only layer that is set that way. But even being set to 3, shouldn’t it just engrave the fish and go over the top of it for the other two passes? Why is it shifting the layer over each time? The other thing that is strange is that it started engraving the fish way too far over from where it should have been.
It should have started a little right of center. Regardless, I will change the passes to 1 and set it to bi-directional like all the other layers and test again.

Hi Dan, It will be interesting to see what difference bi-directional makes. I have a couple of questions…

-With settings as they were (including the 3 passes), if the layer 1 fill setting is changed to “Fill all shapes at once” - do you still get the triple image problem?

-Looks like the “phantom shift” is about half the width of each individual shape - if you replaced the fish with 3 circles each with an offset, of different sizes (but put all in in one group). (But leave all settings the same including “Fill shapes individually”) would you get the effect in this pic on the bottom row? If so, please share the project file, a pic, and a screen shot of the preview showing traversal moves also.


Could you also please share a screen grab of your Optimization settings.

1 Like

I just ran your file as is. Only thing I changed was the size and I had to set the start from to current position.

The burn on the left… I forgot to turn on the air

Nicholas, I will try some of these things later today. Where do I find the optimization settings? I am not as well versed in Lightburn just yet.

What laser did you use? That is backwards. It should be inverted horizontally.

I have an OMTech red and black. It homes to the rear right. I’m assuming yours homes to the rear left. I wanted to run your file without too much modification. The optimization settings are in the lower right of the laser window.

I believe Nic is after this,

This is the settings. I have never used this screen. Is there something that explains these settings?

Yes, Mine homes to the rear-left. If your’s homes to the rar-right, that would make sense as to why it is reversed.

Our documentation and videos, yes. Have you taken the opportunity to looked there? I suggest our entire documentation offers learning value.

Nic might also be looking for the Cut Settings for that layer. In particular,

Thanks Dan, I was wanting to check if you had any unusual settings in this area - but your optimization settings are normal - per factory setup.

Did you get a chance to try the “Fill all shapes at once”? in cut settings?