Upgraded from grbl 1.1e to 1.1f and 40mm of travel instruction has become about 5 inches

I upgraded my flash on my ManaSE controller to 1.1f, reset the $32=1, and was trying to get set up to do a project in the 380-x by 290-y space of my engraver. I tried to use the laser position button to go to the upper right hand corner so I could align my target, and the laser moved to the upper right hand corner of my machine and I had to hit ‘stop’ to keep it from trying to go further… I then used the move command window to do a 40x40 mm move and it went 5" by 5". What do I need to do in order to have the machine only move the correct number of millimeters? Everything is set to use mm. Is there something in the “$” codes that needs to be changed–I could not find a list of those codes in the documentation.
Thanks, Jim

If you flashed a new version of GRBL onto the controller you’ll likely need to redo the config. Steps per mm values are stored in $100 and $101 in the firmware settings. Read here for GRBL configuration: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration

Do you have a screenshot copy of your previous $$ settings?

The $100-102 were the problem! I had a copy of the $$ params from the 1.1e as it came from the factory, and by changing them, it now works correctly.

STOCK 1.1f FR0M 1.1e

$100=250.000 $100=80.000

$101=250.000 $101=80.000

$102=250.000 $102=80.000

$110=500.000 $110=5000.000

$111=500.000 $111=5000.000

$112=500.000 $112=5000.000

$120=10.000 $120=200.000

$121=10.000 $121=200.000

$122=10.000 $122=200.000

$130=200.000 $130=380.000

$131=200.000 $131=290.000

$132=200.000 $132=100.000

I took the opportunity to set the 130s to the size of my area, and the 120s to the same acceleration factor. I just cut a new plaque and it looks really good with the power control on the laser. I will recommend this upgrade to all of the elekslaser A3 Pro users!!! Thanks for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.