Upgraded S9 it's connecting but nothing else happening

Please be gentle with me here, I am very new to this and have very little experience. I purchased a S9 about a year ago for some personal projects and I loved the laser.

I decided to upgrade it with Limit switches a few months back and went through that process relatively unscared. So this month I picked up the Air assist kit with the 32bit board. This is the kit that can automatically turn on the air assist using Lightburn.

I got everything installed and it fired right up and after manually adding the limit switch macro. It seemed to be working fine till I tried to frame a box. It would home fine and as soon as it would frame it would start rubbing and slam against the limit switches.

I did a little googling and updated the firmware on the board with the Sculpfun 32 firmware from their limit switch video.

Now lightburn connects but nothing works. Lightburn finds the S9 on the com port, connects to it. I get a weird GBRL error that I can find nothing on. Doesn’t move when homing, No movement of the laser, nothing.
Error:
Waiting for connection…
ok
[VER:1.1.2022072601:]
[OPT:MPHS]
[MSG:Using machine:XY DLC32]
ok
Homing
ALARM:9
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
ok
Grbl 1.1 [‘$’ for help]
Your Grbl may not support Variable Power mode (M4)
If your laser does not turn off between cuts,
switch to the GRBL-M3 device
[MSG:‘$H’|‘$X’ to unlock]
[MSG:Caution: Unlocked]
ok

Any help would be appreciated

Here is my GRBL output:
$$
$0=10
$1=25
$2=0
$3=0
$4=0
$5=1
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=3
$24=200.000
$25=3000.000
$26=250.000
$27=3.000
$28=1500.000
$30=1000.000
$31=0.000
$32=1
$38=1
$40=1
$100=80.000
$101=80.000
$102=250.000
$103=100.000
$104=100.000
$105=100.000
$110=6000.000
$111=6000.000
$112=1000.000
$113=1000.000
$114=1000.000
$115=1000.000
$120=1000.000
$121=1000.000
$122=1000.000
$123=200.000
$124=200.000
$125=200.000
$130=410.000
$131=400.000
$132=200.000
$133=300.000
$134=300.000
$135=300.000

Those settings look ok from a first glance. I think the kit includes the S30 series mainboard. You can try to use the firmware provided here: Firmware Update & Settings - Diode Laser Wiki But be aware that you need to reset some settings after flashing. E.g., the limit pins need to be inverted usually ($5=1 as in your settings above).

If you do a fresh start, can you move the head using the arrow-buttons?

The console output looks fine. The error about the homing is that it tries to find the switches, but never reaches them. Maybe the pressed switches are not recognized anymore.

That worked! Thank you! The S30 firmware was the issue.