USB Device Not Recognized


(Ben) #1

I have Lightburn working well with a Windows 10 laptop. I tried installing on a Windows 7 pro laptop. When plugging in USB, it says ‘USB Device Not Recognized’.

In RD Works I get ‘Communication Failure’ as well. As the other Laptop works, it doesn’t seem to be an issue on the laser side.

I’ve tried installing FTDI drivers to no avail. Thoughts?


(Ray Kholodovsky) #2

Run Windows Update?


(Ben) #3

Only optional updates were availible - nothing that that had been downloaded or pending update.


(Phil Stevens) #4

Definitely going to be a driver issue.

What is showing with an exclamation mark in device manager?


(Oz) #5

You could try going to the windows device manager, finding the device there (it’ll show as unrecognized, or similar) then uninstall any driver associated with it. The Ruida machines do use the FTDI device, but it’s possible the driver is corrupt. Nuking it and reinstalling might do the trick.


(Ben) #6

Still fighting with this… Double Checked that the other PC does still connect with no issues so it’s not a hardware issue.

In Windows 7, I’m seeing this message:
USB%20Issue

I’ve deleted the device/Driver and reinstalled drivers from multiple sources (RDWORKS, Cloudray, Lightburn, FTDI directly)

I’m seeing it as Unknown Device in Device Manager - Sometimes with the Warning ! and sometimes without>

I’m curious which of these drivers I should select when given the choice - It’s not automatically selecting this for me. I presume the USB Serial Converter - but there is a list for these from A - G.

Driver%20Options


(Isaac Barbary) #7

That looks like the wrong driver. Download this and give it a try.