User origin issue

CO2 with Ruida controller. When using absolute coordinates things work ok. When I select user origin and there are objects outside of the cut area the origin moves to the extreme perimeter of all the objects.First pic is the cut area with absolute coordinates, second is the same screen only zoomed out to view objects outside of the cut area and set to user origin. Notice where the green dot is in each.

Select only the objects you wish to cut, then enable ‘Cut Selected graphics’ and ‘use selection origin’…

Do you get an warning from Lightburn when you use absolute coordinates?

Good luck


No warnings with absolute coordinates. I’ve been using only that for years and just started with the other options to check them out recently. I will try selected graphics but why should I have to? I think if things are outside of the defined cut/bed area they should not be considered as usable anyway.
Ok I tried ‘cut selected graphics’ and it behaves the same. The green dot is still in the same spot and I still get a warning when trying to frame or cut if ‘user origin’ or ‘current position’ are selected.

Make sure you also toggle “use selection origin”

That just brings the green dot to the corner of the bed, not the user origin.
Ahhh I take it back. It does move it to the corner of the bed but when graphics are selected it is correct.

With no other graphics outside of the bed area it performs properly without selecting ‘cut selected graphics’ or ‘use selected origin’. Seems the program could be made to ignore anything outside of the bed area for origin concerns. If something is protruding from the bed area to outside the bed it throws a warning so it must know.

I remember seeing a youtube vid that said it would ignore anything outside the bed. Don’t know if that changed in a newer release or what. But it would be nice to have.

There is a toggle switch in General Settings… ‘Ignore out-of-bounds shapes if possible’

Yes there is and mine is toggled on so that didn’t help the situation. Thanks anyway.

Same here.

Mine will do the whole job, inside or outside the work area… I’d expect this so I don’t think it’s a bug…


Mine throws a warning when I try

I have wondered how to get around this myself. I haven’t seen a “solution” in the conversation, so far, so I am wondering if this is actually a bug.

Keeping drawings outside of the working area is pretty necessary for a number of reasons. But, when you do that, it seems to mess with your “start from” coordinates, as has been described in the post previously.

Basically, I guess I’m mostly just piling on, and saying “yeah, I have the same issue”.

Not a solution but rather a work around. Using ‘Cut selected graphics’ and “Use selection origin” makes it work it seems. I haven’t actually tried it on the machine yet but it seems to be viable in the program from what I have seen. Perhaps we will get the ‘Official’ word on this pretty soon!

I tried it yesterday and it did work fine.

1 Like

I thought maybe @LightBurn would chime in on this…

The behavior is as designed. When using Absolute Coords, the grid matches the working area of the machine, so it’s trivial for the software to see what’s outside the work area and not send it.

When using User Origin or Current Position modes, there is no correlation between the grid in LightBurn and the work area of the machine, so we can’t trivially discard things that are out of bounds. You have to use ‘Cut Selected’ and ‘Use Selection Origin’ as you’ve found.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.