Using national characters in variable text

Hello all

When writing text in LightBurn, it accepts national characters without any issues, but when using variable text with national characters, the national characters are scrambled.
I have tried playing around with the encoding of csv file but no luck. I also tried some other fonts but with the same result.
Any ideas how to get it to work?

Best regards

what are “national characters” ?

National characters are… Well, special characters in you national keyboard layout :slight_smile:
I am from Denmark, we use æ, ø and å, which will probably look like gibberish on your screen because you do not have a danish keyboard (assumption on my part :smiley: )
In other words: Characters not in the a-z range.

I hope that cleared up my question.

Yup! That’s what I thought, but wanted to be absolutely sure. And those characters show up fine here.
Could you provide a screenshot of what it looks like on your screen in LightBurn?
Also, would you mind uploading a project file and the csv file you are using here? That would greatly help me diagnose what’s going on.
Also, what version of LightBurn are you running?

I am using version 0.9.21

guests.csv (48 Bytes) saveTheDate.lbrn2 (25.1 KB)

Thanks for the files, that was super helpful!
So this is a tough one - we let the code framework we use (Qt) decide how best to load the csv files. This is really the only way to do it because users could save their files in any of dozens of encodings and, in theory, the system should just do the right thing. But it’s clearly not - I can reproduce it easily on my end, even with my system language set to Danish (I actually do have Danish input settings installed :slight_smile: )
The csv file you sent is encoded as UTF-8 which should just work but I was only able to get it to work when I forced LightBurn to load it as UTF-8 (by updating the code).
I did however, get it to work by resaving the CSV file in a UTF-16 encoding.
No idea what text editor you are using, but if you can’t get it saved in that format let me know what editor you are using and I’ll see what I can do to help. Hopefully that should solve the issue for you.

I’ll be having a conversation with @LightBurn to discuss what we might do to solve this so you don’t have to tweak the encoding settings every time.

Well, you know what they say about assumptions :wink:
I am using Notepad++ and converting the file to UCS-2 LE BOM actually makes it work here as well. I thought I tried that one as well but apparently I did not.
Problem solved, thank you very much for you help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.