V1.1.03 Out of Memory Error on Preview Render

Screenshot 2022-03-11 215340

I tried adding the LBRN2 file but said it was too big (max 4 MB)

Support Data.txt (6.9 KB)

This Lightburn project is a png of the marines raising the flag at Iwo Jima. When trying to preview the final pass which the instructions say should be lasered at 535 LPI I get an Out of Memory error.

You are trying to do a gray scale with very high definition, tough in the best of times.

The amount of gcode produced had to be gigantic.

You will have to hope @LightBurn chimes in, as I don’t know how to handle this…

If you have access to something like Google drive, you can put your .lbrn2 file there and drop a link to it here.

Ensure you set it to anyone with the link can read it…

Great image :+1:

Good luck


You are correct, this is a grayscale image. At 400 DPI no error message. At 500 DPI the out of memory error. Seems as though the amount of memory the PC has, that dynamic allocation of memory, should be able to aquire enough to accommodate this process. I suspect the program has a had limit set somewhere.

You’re using grayscale on a CO2 laser? Have you done this before?

It is unlikely to work well, which is why I ask - dithering is much more predictable. Grayscale tends to be variable depth, not variable shading, as it says under the sample swatch.

Are you running the 64 bit or 32 bit version? The 64 bit should be able to handle this scale.

Thanks… For some reason I though he was using a grbl machine…


I am running the 64bit DSP version. I have not but will try dithering to see if that makes a difference.

I will say that without fairly specific lenses, you’re unlikely to get about about 318 DPI (0.08mm dot size). With a 100w laser, you’re more likely going to get in the 200 DPI range (0.125mm dot size), or even lower, at least on wood.

Is this a purchased, pre-dithered image? I can see what looks like dither patterning in it already, in which case your best option would be to turn on the pass-through mode, and just let the image itself dictate the DPI.

Are you new to all this, or have you used grayscale images at this DPI before? (I’m suspecting new, but I don’t like to assume)

Thanks for the info Oz.

The is an image that i purchased for 3D engraving and the seller provided setting to engrave on a Glowforge. The settings are 3 passes in L/CM starting at 96 and going up to 512. Converting to LPI the numbers are way high so just trying the settings as if they were LPI.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.