Vector and PNG image not lining up on engraving


(Larry) #1

Bodor BCL1309 with newest Ruida Controller. (Machine is 2 weeks old)

My son is working on a PNG file which we test engraved with great results. I decided to create a vector image to cut/darken the borders around the image and also cut the text instead of scanning them.
The PNG image is in black (Image)
The vectors are shown in red and blue, red is set “line”, blue is set to “fill+line”.

The layers are in perfect alignment in Lightburn, but when I run the file, the vector files (blue and red) are out of alignment with the image (black).
I have thrown away the test cut, but the second photo is a representation of the final outcome.

I have tried everything I can think of and can not figure it out. Any help would be greatly appreciated!

Everything was created in Inkscape, the image saved to PNG and the vectors were saved as Optimized SVG.

I am very new to laser engraving and just assumed this is the best way to do things…Am I a complete noob and have simply gone about this the wrong way? Seems to me that this should work with no problems at all.


(Larry) #2

Wait…I just tried to save the file again in inkscape and have gotten this flowtext warning…could this be the culprit? I have no idea what flowtext is but know that all the text has been converted to paths.

Thank you so much in advance for any advice you may have!


(Oz) #3

Hi Larry - a couple questions:

  • Are things lined up when you preview?
  • Do the lines on the Fill+Line layer properly align with the filled part?

(Larry) #4

Hey Oz,
Yes everything is aligned BANG ON! Even when zoomed all the way in.
I even deleted all text and retyped in lightburn as well as recreated the border. This made the text shift to the left instead of the right, though.
I did try something that seemed to help, I switched off flood scan and also grouped the layers. That shouldn’t make a difference, would it?


(Larry) #5

This was after recreating fill/cut borders on lightburn…same issue. This particular test was only one file so I could rule out alignment issues. This was with flood scan anabled. After switching flood scan off, it seems to be ok.


(Oz) #6

Don’t use flood fill for a Ruida - the hardware doesn’t like it except in the simplest of cases, and the way that it moves can cause slippage if the acceleration settings on the machine are too high.

This keeps coming up, so I’m going to have to disable that option for this hardware until I can figure out how to form the paths in a way that doesn’t cause problems with the controller.


(Ray Kholodovsky) closed #7