Vectorworks DXF File problem


I need some help with DXF File from a CAD program Vectorworks - I’ve exported it all and it’s on my computer. When I tried to import it into Lightburn - it won’t open. I really need this solved by Tuesday as a client is waiting for me to have this ready.

I’m really panicing! HELP!!

If you’re able to attach your troublesome DXF here I’m sure someone will be able to help.

Hi there,

Here’s the file: [DXF] (Microsoft OneDrive)

If anyone has solved this for me, I really appreciate it!
Many thanks

I opened the DXF in CorelDraw and then transferred it to LightBurn using the LB/Corel macro (I could’ve manually exported it from Corel then imported into LB but I was feeling lazy!). I haven’t looked into why this wouldn’t import directly yet but I’ve attached a new DXF (re-exported from LB) as well as an LB file.

I’ve had to zip them up as they wouldn’t attach (due to file size I think). I also had to add a .txt extension so that the forum didn’t reject it. Just remove the .txt from the file name after you’ve downloaded it and then unzip it.

Hope this helps.
Peacock sperated - MRW (2.6 MB)

Ok, I’ve found out why it wouldn’t open in LB… It’s a binary DXF rather than a text DXF. LB will only open text DXF’s. If there’s an option in Vectorworks to export as text (ASCII) DXF then this might work better for you in the future.

Here’s a better LightBurn file. There were over 8400 duplicate objects and everything was made up of short lines so I’ve “Auto-Joined” everything and “Closed” the paths where necessary. You might find this works better than the first version posted above.
Peacock sperated - (984.2 KB)

1 Like

Apologies, I’ve noticed some missing vectors in the files I’ve given you. I’ll see if I can get you better versions as soon as I can.

It was way past my bedtime when I posted last night and it was all done in a bit of a rush. There were a ton (or tonne if you’re metric :smiley:) of nodes which is what made the files so large. I’ve now had time to improve the files by reducing the number of nodes massively (I did this in CorelDraw). They’re still not perfect as there are vectors that overshoot and don’t meet other vectors when clearly they should. Here’s an example:

I’ve attached both DXF and LB files (notice how much smaller the files are due to the reduction in nodes). Note that the DXF (which has been exported from LB) has more nodes added again by the LB export process so is less optimised than the LB file.
Peacock sperated - MRW (reduced nodes).lbrn2 (529.7 KB)
Peacock sperated - MRW (reduced nodes).dxf.txt (1.3 MB)

Hi Marcus,

Thank you, Thank you, Thank you, Thank you!!! For the file as it’s what i wanted.

Now it’s telling me it will take 9 hours to cut and engrave my project - It’s all coming up as black vector when i preview before starting the laser machine. It shouldn’t be showing like this! For other projects - it only took me 20 mins

i also have tried exporting it as DXF text and nothing happens and that why & where I don’t understand.

You’re welcome. I had just finished working on those missing vectors when you posted, so please find attached file.

The missing vectors were in these parts circled in red so I just redrew them:

You might still need to do a bit of editing to get the end result you’re looking for but hopefully it’s now pretty close. Let me know if yiu need any further help and I’ll see what I can do.

I don’t know which areas you want to cut and which you want filled so you’ll need to set each layer according to your requirements. If there are any areas that should be filled and aren’t it will probably be because of disjointed objects. These will need joining using the various tools available in LB such as the node edit tool etc.

Peacock sperated - MRW (reduced nodes).lbrn2 (517.5 KB)

ps: if you could post a screenshot of what you want the final design to look like (perhaps a screenshot of how it looks in Vectorworks?) we might be able to offer better assistance.

Sorry to step in.

Maybe I`m doing somethig wrong but it gave me 3(CAD?) layers
with a size of 375mm x 347mm, when opening yours the size is 210mm x 194mm, Won’t there be problems with the slots?

1 Like

To be honest I didn’t check sizes, I was more interested in getting it into LB in a usable state. I didn’t apply any scaling myself but it is possible that one or more of the import/export stages has scaled it. I’ll take a look and see if I can determine if anything’s gone wrong in that department.

As for the layers: Yes there are three layers in the original DXF file. LB ignores the DXF layers and instead uses the entity colour to determine which LB layer to put it on.


Ok, I’ve had a look and I’m not sure where the scaling issue was introduced. Anyway, I’ve now rescaled the LB file accordingly and attached it below.

Thanks for noticing this!

Peacock sperated - MRW (reduced nodes).lbrn2 (522.4 KB)


Hi Marcus,

Thank you so much for all of your help!
Everything came out perfectly - just what i wanted!

1 Like

That’s great, I’m pleased you got the result you were after. Thanks must go to @parsec as well for noticing and pointing out the scale error that introduced itself somewhere along the line!

If you wouldn’t mind marking one of my answers as the solution it could help others looking for a resolution to a similar problem in the future.

1 Like

From your pictures it seems you have mechanical issues, your circles aren’t circles.
Are you using air-assist?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.