Veritically inverted

Somehow Lightburn defaults to print/burn vertically inverted. I am sure it is a setting somewhere. Any suggestions? Thank you

xTool D1 requires your machine origin in Device Settings to be set to top-left. If you haven’t, I suggest you use the device configuration file found on xTools site as it includes other relevant configurations for your laser:
https://support.xtool.com/hc/article_attachments/4414379634455/xTool_D1.lbdev

1 Like

Hi Kevin. I am also having that problem and also my design looks perfect on the computer but when I send it to the laser, it burns it like mirror, that is somewhat inverted. I hope I can explain my self and hopefully someone will give us some thought on these problems. By the way I am running Lightburn in a MacBookPro TB M1 with Monterrey . I mention these because I had this inversion problem in another software and the culprit was the MacOS very much to my surprise.

Thank you for the info. I re loaded the “Device Configuration” that you suggested and everything seems to be corrected now. I will make a couple of runs to test it. TKU Very much !!!

1 Like

Mine is a MacBook as well. As soon as I can open the above article I will continue to work on the issue. have you opened it?

Hi again Kevin…

I downloaded the driver as suggested and everything is now working properly. I hope it helps you too. Forget about my comento on the MacOS as it was obviously a problem with the driver and that has been solved. Good luck to you and happy lasering!!!

Hello! For some reason I can not get the article to open. Which driver did you load? Thanks

It’s not an article. It’s a direct link to the .lbdev device configuration file that you can import into LightBurn. If clicking the file doesn’t directly download try right-clicking and do a save link…

Thank you PY. Forgive my inexperience with Mac. I have minimal experience with this platform. It was my wifes old notebook that wasn’t being used.

Trying to load the .lbdev file. I tried to load it hooked up to the D1. Went to device, xtool, then tried to import. It would not let me. I deleted xtools and reloaded it samething happened. I am kind of at a lost how to load the above file. it will not highlight or give me an option to run it. Thank you

  1. Push Devices button in Laser window
  2. Individually click and Remove all current entries
  3. Push Import button
  4. Select the downloaded .lbdev file

You should now have one entry for your laser in the Devices list.

That is what I have done. I have noticed that using the above link it is saving it as a .txt file so I guess that is what is keeping it from highlighting to be able to be ran.

It should not be a txt file. It should literally be named “xTool_D1.lbdev”.

Try opening the file using Finder. The contents should look literally like what I have below. If it does, then rename the extension to .lbdev rather than .txt. If it doesn’t then re-download the file. Worst case you could try to create a new file using the content below.

{
    "DeviceList": [
        {
            "DefaultCutList": [
            ],
            "DefaultToolCutList": [
            ],
            "DisplayName": "xTool D1",
            "EnableLaser2Offset": false,
            "EnableProcessOffset": true,
            "Height": 406,
            "HomeOnStartup": false,
            "Info": "",
            "Laser2OffsetX": 0,
            "Laser2OffsetY": 0,
            "LastCamera": "",
            "MirrorX": false,
            "MirrorY": true,
            "Name": "GRBL",
            "ProcessOffsetX": -16,
            "ProcessOffsetY": 0,
            "ReverseIntervalCompensation": true,
            "ReverseIntervals": [
                {
                    "LineShift": 0.07999999821186066,
                    "Speed": 50,
                    "StartAdjust": 0
                },
                {
                    "LineShift": 0.15000000596046448,
                    "Speed": 100,
                    "StartAdjust": 0
                }
            ],
            "Settings": {
                "AirAssistM7": false,
                "BaudRate": 230400,
                "CommPort": "cu.Bluetooth-Incoming-Port",
                "EnableBoundsCheck": true,
                "EnableDTR": false,
                "EnableGrblJCommand": false,
                "EnableUserFinish": false,
                "EnableZ": false,
                "EndGCode": "",
                "LaserFire_Enable": true,
                "LaserFire_Power": 10,
                "Macro0_Content": "\n",
                "Macro0_Label": "Macro0",
                "Macro1_Content": "\n",
                "Macro1_Label": "Macro1",
                "NegativeZ": false,
                "OptimizeZ": false,
                "Pen_AbsDownPos": 0,
                "Pen_AbsUpPos": 0,
                "Pen_DownDelay": 0,
                "Pen_Enabled": false,
                "Pen_Type": 0,
                "Pen_UpDelay": 0,
                "Pen_ZRelChange": 0,
                "RelativeZOnly": false,
                "S_Scale": 1000,
                "Sim_CornerTolerance": 0.009999999776482582,
                "Sim_FastWhiteScan": false,
                "Sim_FastWhiteScanSpeed": 0,
                "Sim_GlobalFactor": 1,
                "Sim_MaxAccelX": 3000,
                "Sim_MaxAccelY": 3000,
                "Sim_MaxSpeedX": 500,
                "Sim_MaxSpeedY": 400,
                "Sim_MinCornerSpeed": 1,
                "Sim_RapidSpeed": 400,
                "Sim_ScanAccelX": 3000,
                "Sim_ScanAccelY": 3000,
                "Sim_SpeedFactor": 1,
                "SkipWhiteFlag": false,
                "SkipWhiteSpeed": 0,
                "StartGCode": "M106 S0",
                "TabPulseWidth": 0.05000000074505806,
                "TransferMode": 0,
                "UseG0ForOverscan": false,
                "UserFinishX": 0,
                "UserFinishY": 0,
                "UserOriginX": 0,
                "UserOriginY": 0,
                "mirrorRotaryOutput": false,
                "rotaryAxis": 2,
                "rotaryDiameter": 17,
                "rotaryIsChuck": false,
                "rotaryMode": false,
                "rotaryObjDiameter": 50,
                "rotarySteps": 360
            },
            "Type": "Serial",
            "Width": 432
        }
    ]
}
1 Like

Thank you. I did all you asked. It still will not load. I rebooted after I created the new file. I am sure it is something simple. I am going to step back for a moment and regroup later on. I appreciate all the information and your assistance.

When you get back to it can you take a screenshot of Finder showing the file and also the file open?

1 Like

Thanks PY. I downloaded it to my work computer put it on a thumb drive and loaded it that way. A couple of little hiccups. deleted and reloaded and it seems to be working correctly now. Thank you for your insights and patience with this old codger. Now my RA2 just showed up LOL

Fantastic. Got through the short-term pain but hopefully works better for you now.