Very slow when trying to select a new font

Windows 10 , Version 0.9.04

In the last few weeks I have noticed that sometimes when I have text selected and click on the font drop down to change the font, and then move the cursor into the drop down list (but before I even click on a new font) I get a popup window (Title of the Window is LightBurn 0.9.04) with a status bar that moves left to right. Normally the font of the selected text just quickly redraws in the font the cursor is hovering over. But when this weird condition is occurring the font of the selected text does not change as the cursor hovers, the status bar is just displayed and then when the status bar is complete the text still does not change font.

Sometimes the status bar moves very quickly, sometimes it takes about 3 or 4 seconds to complete.

I checked my font library and I have about 450 fonts loaded if that makes any difference.

When it takes a long time to complete, do you have a lot of text displayed? It’s possible that rebuilding the text and welding the result is what’s taking the time, and that happens as you choose new fonts.

Now that I have the “preview” mode (used for text on a path) I could flip into preview while you’re selecting so it does less work, then flip it back again when you’re done to finalize it.

I only have 1 word with 10 characters selected, the text is about 1 inch tall

Some fonts have a lot of geometry in them, like ‘noise’ - is that a possibility?

I do have some fonts that are designed to mimic old whisky bottle fonts, I guess they could be called noisy.

This is one if them called Absinthe Full

That will likely be why - if you turn off welding on that it’ll go much faster. In the meantime, I’ll look at turning on the “preview” mode while you’re selecting a new font, so it won’t weld until you’ve made your choice.

Turning off the Welded option fixed it! Thank you.

I’ve updated the code to clean up a few things:

  • Text is shown without welding while the font chooser drop-down is displayed
  • Undo entries aren’t created for every choice you make in the drop-down any more

These will be in the next update, though for your case, if you’re using text that doesn’t need to be welded, you’re likely better off just turning off the option.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.