Vigotech L7 with Lightburn

Hi everyone,

I have a Vigotech L7 laser engraver and I changed it’s firmware to GRBL. It works well with Laser GRBL program, but it won’t work with LightBurn. Do you know where it can be a problem? When I open the Lightburn, in ‘‘Console’’ section it’s written ‘‘Waiting for connection’’.

I really red every topic on this forum that it’s connected with this topic and this laser, but I just can’t find the solution. The laser is connected with USB, not WiFi. When connecting in LightBurn, I tried to set the controller to GRBL, and to GRBL - M3 and still does not work. Also, I set the right COM port for the laser.

Please help :slight_smile:


How did you do this? Where did you get the firmware?

Can you confirm this is the same port as used in LaserGRBL?

You want GRBL unless your version is 1.1e or less. Only then would you consider M3.

Can you send screenshots of Edit->Device Settings and also full screenshot of LightBurn while you’re attempting to connect?

I found it on internet. Just googled it. I solved the problem, sorry for disruption and thanks for commenting!

Can you document the fix here so that others can benefit?

Yes, of course. First I downloaded firmware from this link: Flashing Grbl Firmware – LaserGRBL v1.1h, original 20190825

Then I downloaded XLoader and uploaded that firmware. Set the right port and turn the LightBurn on. After that, the Lightburn recognized my laser and now everything works. I guess, I haven’t had the right firmware. This one, (link that I posted) works great.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.