Waiting for connection LB 0.9.21, 22,23,24

Hi, I need some assistance from this very knowledgeable forum. I’ve been using lightburn for years now with no issue, I haven’t updated since version 0.9.19. Today I updated my subscription and downloaded the latest version (0.9.24) but now I am unable to connect to my laser. It says “ready” but in the console it only has “waiting for connection”

I’ve tried versions 0.9.24 to 0.9.21 and have the same issue but version 0.9.20 works fine.

I’ve also tried DTR enabled but nothing, also changed the baude rate on the software and the laser cutter but also no change.

Please note that my previous version 0.9.19 has worked flawlessly for years (except for the rotary setup which appears to be a bug in that version), and the only change I did was to update the software. The software goes back to working state when I downgrade to versions 0.9.20 or 0.9.19

Setup - custom made C02 laser cutter using Marlin bigtreetech skr1.4 turbo.

I cannot be the only one with this issue and would love any feedback to have this resolved.

Thanks in advance!