Waiting for Connection...Monport

I have poured over dozens of posts with this similar issues, but none of the recommendations have solved.

I have a Monport 40W. I have been using it for almost a month with the trial version of Lightburn. Today, I am unable to connect my laser. I initially thought it was due to the trial ending and purchased the liscense. Additionally, I updated to the latest Lightburn version.

It says “Ready” on the laser screen, but when I try to send the job - there is no reaction. If I try to send again it gives the warning that the laser is busy or paused.

Lightburn cannot detect the laser, so I manually reinstalled it - still won’t send the job.

I have done the following:

  • power cycled both laptop and laser; various disconnecting/connecting sequences.
  • reinstalled Lightburn software.
  • confirmed driver is latest version.
  • Replaced USB cable.
  • Confirm computer is detecting laser through Device Manager.
  • Cycled through all com options; the incorrect coms show “Port failed to open - already in use?”, the correct com just shows “Waiting for Connection”.

Any other advice?

Have you verified you are communicating on the proper comm port? If you first open a different project window, then by chance, copy and paste to another LB window, the port will not follow, rather it’ll stay on the first window opened. The only way I have found so far, is to either close the first window or manually change its port to some other comm port. Then reassign the second window port to the correct port.

1 Like

I don’t follow. I only have one project window open.
The laser is plugged into COM3 - I have confirmed through Device Manager.
I have also tried moving to another USB port on my laptop (it switches to COM6) and that will not connect either.

Touch the “Home” button then does the machine move back to the home position? If not, it’s not communicating. If it works on comm 3 then that’s essentially the standard one for it. Yes, it can be changed. For now though, verify you are communicating with the machine via the correct port

Had the same issue.

I got my computer to see it by turning the laser off, disconnecting the USB, turn the laser back on (while disconnected) then reconnecting the USB.

At that point, it would reconnect, but would stop firing after a split second when I hit play. I checked for updates in Lightburn, there was one, installed the update and everything worked again.

Hope this helps.

Issue solved.
I actually went in and adjusted the baud rate, which caused a series of errors in the console.
So I put it back to the original setting and it connected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.