"Waiting for connection..." over and over and over. But it worked the first time!

Hi there - I just set up my Ortur Laser Master 2 and downloaded the latest version of Lightburn (still using the 30 day trial). Lightburn immediately recognized my laser and the setup process was much easier than I thought. I went to work and quickly burned my first project. Then, a few hours later, I came back to work on a new project and now I can’t get Lightburn to connect!

The “Console” tab just shows “Waiting for connection…” No change if I right click on “Devices”. I checked to make sure I had the latest software update and I do. I’ve quit and restarted Lightburn (and my computer…oh yeah, I’m on a Mac, if it helps). I tried different USB ports. I’ve powered down the laser and powered it back up. The laser, itself, does appear to be on. I’ve even disconnected my laser from Lightburn and added it. Upon doing so, Lightburn recognized my laser yet again, but still won’t connect.

Why would it have worked so flawlessly the first time and now I can’t get it to connect at all?!

I’ve been chasing the same rabbit through the hunt…

I’m using a Windows 10 PC, and I really don’t think it’s software related. My PC is a few years old now, and I suspect it’s the handshaking of the devices causing the ‘waiting for connection’ issues.

What I have done to get my most frequently used laser to connect is:

Unplug the USB to the laser (my lighturn camera stays pluged in)
THEN I start up the PC and once it finishes ‘chatting to OneDrive, my synlogy NAS, printer(s), mail servers’ etc …
I start LightBurn, then;
I start the laser.
THEN I plug the USB from the laser into the PC, watch the console tab in LightBurn, and once it shows the firmware etc…
I run a macro that says ‘use LASER’, which has ALL my current settings defined in it.

Then, since my laser parks in the top right (to get out of the way), I move it to the LOWER LEFT, restart LightBurn, and it finds it right away.

I’d like to use the “Get Position” on the ‘MOVE’ tab … but it doesn’t seem to do much of anything.

So THAT’s my startup process… I really hope it helps - and again - it’s a bit tedious - but LightBurn works SO well, that it’s not really that big of a deal to get such great results, with a couple of minutes in the start of a productive day…

Thank you for your input, @JMichael. I was able to figure it out…and it was a dumb reason. Next to the “Device” button is a dropdown to select the source of your connection to the laser, and for some reason, mine was defaulting to “bluetooth” instead of “usb”.

So after all that troubleshooting, it was because I didn’t bother to look at, and change, that dropdown lol.

Glad to hear it worked! This is such a busy screen, and until you get inside the developers’ mindset … it can be pretty overwhelming! … but once you get to sense how this DEV team thinks about the workflow … WOW! Great software :sunglasses: