Weak laser after installing lightburn

I have a 60w co2 laser with ruida control. I was using lightburn trial program and the laser worked great. So I purchased the program and installed it, now the laser is super weak when running a program no matter what power level is at. I thought it was the power supply, but the laser fires up fine when I press the pulse button.

Any advice?


Already browsed thru those and didn’t find the answer. I appreciate your effort.

A couple things:

  • you said “no matter what the power level is at” but the power level is two settings, and how they work is affected by the speed. What settings are you trying to use?

  • have you tried also using RDWorks to run something, to see if the problem is there too? If so, that would point to a hardware issue. If not, it would indicate software, and help pinpoint the cause.

1 Like

Thank you for your reply. I am just trying to CUT a piece of cardboard at super slow speed and it doesn’t even leave a mark. The power level on the machine is at 100%, with your advice, I will go in and see if where else can I set the power level at.

No I don’t have any other software, I got the machine about a month ago and I went straight to using LightBurn from the very beginning and it worked fine for the whole month until I purchased LightBurn license and entered the software code.

I appreciate your reply, I will go in later today and see if I can find more settings. There was an update for LightBurn yesterday on my computer, so I’ll see if that fixes my issue.

Thank you.

What is your MIN setting in the cut settings editor?
At speeds below 10mm/sec, the ruida controller uses the min setting only. If it’s set to 0, then you get 0…

1 Like

UPDATE: Thank you for the advice. After the software update (the day after I purchased the license), the laser fired right now without having to do any setting changes. I appreciate everyone’s input. Thank you very much!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.