Weak laser power in fill mode

Hi there. I have a problem with laser strength settings in FILL and other modes. It doesnt matter which value I set, the power is still the same - kind of weak.

The only way I can get stronger laser is to slow down the moves.

My chinese laser is added manually as GRBL.

Pls help

What speed/power are you trying to engrave at?

type $$ in console and post result.

Thank you for your reply

You answered half of the question - What speed / power were you trying to use? It’d be best to show a screen shot of the speed/power settings from the Cuts/Layers window, and include the part below it that shows the units the speed is in (mm/sec or mm/min).

Here you go.

On other software I could set the speed to 6000 and the strength of the laser was double as here on 3600.

Can you check the value of “S Value Max” in Device Settings? If it’s not set to 1000, change to 1000.

Its also 1000

How are you determining the relative strength of the laser in other software? Seems your basic settings for power level are correct.

What other software are you comparing to? Can you save gcode using a .txt extension from both applications and post here?

I see how deep the laser can go into the wood with the same speed here and in vigoworks

Im attachingnthe file you are askibg from lightburn. The other software vigoworks doesnt have that option.

The laser is VGL-7 chinese 20w laser.
Koral5.txt (22.3 KB)

I can see that the g-code is requesting max power (S1000) so it’s up to the controller to deliver at that point. I don’t see how vigoworks could be actually getting more power so likely something else going on.

Some ideas.

  1. Confirm that the units in Vigoworks is the same as LightBurn. mm/min.
  2. Reconfirm speed.
  3. Vigoworks possibly doesn’t use M4 for laser mode and can only do M3. Try setting LightBurn to “Constant Power Mode” in cut settings and repeat the test. Does this change the outcome?
  1. The same. Vigoworks can work faster and have better results than Lightburn on slower work.

  2. Confirmed.

  3. Try that already. No difference.

I installed vigoworks and checked it out. A couple of things I’m noticing. The line density of vigoworks seems to default to 5 dots per millimeter. That would be equivalent to .2 line interval. You may want to try changing that setting although if anything I feel like that would reduce apparent burn strength.

Try one thing. Take a stop watch and time the amount of time it takes to burn in LightBurn and Vigoworks. What are the results?

One thing that’s a possibility is that Vigoworks use a different firmware than the GRBL mode that’s used. It wasn’t apparent from the software but it’s possible.

Given that there’s an iOS version of their app that is entirely possible. Similar to the LM3.

Im sure that Vigoworks was much quicker. I could see quick laser moves with strong laser.

In Lightburn when laser is working as fast as there, the strenght of the laser is so much lower.

Can see that on the result plus the ammount of smoke in the room :wink:

You’re saying it’s both faster and stronger? That’s odd.

Can you do an actual timing of how long each burn takes? Taking a video might be easier as you can check the exact start and end times. The relationship between the runtimes might give a clue as to what’s going on.

The speed of the moves are the same. However in Vigoworks it can go fast and strong.

In Lightburn to be strong, it has to go slow.

I will make the videos tomorrow.

Thank you.

Try enabling the ‘Constant Power’ switch in the Line layer settings in LightBurn.

If the Vigotec uses an 8-bit controller and is unable to process GCode quickly enough, the laser head would move slower, and would reduce power to compensate. If you enable the ‘Constant Power’ toggle switch, the power will not be adjusted based on the speed of the laser.

I tried that already. No difference.

I must have been misinformed. I thought constant power off was for greyscale setting and min and max

That certainly wouldn’t have come from us. You probably heard that somewhere on Facebook, aka ‘the treasure trove of misinformation’. :slight_smile:

The documentation for GRBL firmware explains how constant power mode works very clearly: