Weird corner burn

When I burn a square it always makes 2 strange corners.
So the square is not equal. Could that be Gcode or wrong settings?
I have a Eleks Maker run by a belt. I tried to loosen or tighten the belt and no matter what speed I am burning it is always doing the same on the same corners.

I can guarantee you this is a mechanical issue of some kind, but I’ve never seen one quite like this. You can verify that it’s not the GCode by clicking ‘Save GCode’, then running it through a simulator like this one:

Those are supposed to be squares? My best guess is that you have the stepper motor ‘idle’ setting enabled, so the motor is disengaging when not used, so it’s not holding position, but that is entirely a guess. Try typing $1=255 in the console (and press enter). That will keep the steppers engaged at all times.

Hi, Thanks for the reply,
$1=255 did not have any effect on the burn.
I think it could be the belt that perhaps miss a few teeth or so.

The GCode seems to be fine.

; LightBurn 0.9.10

; GRBL device profile, user origin
G00 G17 G40 G21 G54
G0 X-70 Y-60
; Cut @ 600 mm/sec, 100% power
; return to user-defined finish pos
G0 X0 Y0

Is there a way to burn (without fill) lines instead of doing the full square?
It seems that if I change to fill the strange offset is gone.

There isn’t, no. Even if there was, it would simply be hiding the issue, not fixing it. I would check to make sure that the assembly is correct, things are moving smoothly without sticking (like bearings and wheels), make sure that all the set screws holding the pinions onto the motors are snug, and so on.


I think I solved the issue by tightening the belt. Guess we all have to go to this for a start :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.