What is this telling me please

I am having all sorts of problems with Origin, Home position and negative space.
Laser is NEJE Master 2S Plus. I have tried following a number of Lightburn tutorials one of which convinced me my machine worked in negative space. I followed instructions to set a workspace offset which seemed to solve half the problem. I have been going back and forth between Lightburn and LaserGRBL trying to see what is happening but getting nowhere.
The image is the top right of the laserGRBL screen. Does it tell me anything useful please.

What led you to this conclusion? I don’t believe your laser defaults to negative space.

You haven’t expressed the problem you’re actually experiencing. Can you elaborate on this?

Additionally, can you run these commands in Console and return the output please:


These are two completely different products, even though both eventually shoot GCode to the controller.

Tell us in detail what issues you are having using Lightburn, and we will try to help you resolve them. There are a lot of NEJE owners on this forum.

I made a simple image, a rectangle with text in it in Lightburn. First line was to engrave the lettering second line to cut the rectangle out. When it engraved the lettering it was a mirror image. I went looking for information to explain this and after reading several documents I came across some information that suggested my laser was working in negative space.

I am at the position now where my machine will home to bottom left but if I try to send to Origin the laser travels all the way to the right on the X axis so it goes to what looks like Y=0 X=440

$H returns it to the Y=0 X=0 point
Target buffer size found



















































Thank you for looking at this for me.

Thank you Mike. From the reading I have done over the last 10 days I had formed the (probably wrong) impression that GBRL set parameters in the laser that Lightburn then used. I think all the reading and what I thought to be understanding, convinced me I could sort it myself if I just read the right things. Turns out that idea was wrong and I have probably confused things. I am grateful for any help I can get.

Can you provide a screenshot of Edit->Device Settings?

I believe the normal homing position for your laser is top-left. Have you changed something?

How are you doing this?

Where physically is the laser head at this point?

Reported position is 0,420. This is what I would expect. And I’d expect this to physically be at top-left of your machine.

Could this be an issue of perceived orientation of your machine?

Is this how your machine is oriented?

Yes a mirror image

Trying to send to Origin using ‘Go to Origin’ button in the Laser controls

Laser is as shown below. As shown is how I assumed the Front of the machine with the short arm being the Y axis and the long arm being the Y axis.

I believe now that I have been perceiving the origin in completely the wrong way.

My machine looks like your image but I rotated it 90 degrees left to make sense of it and put the origin in the bottom left corner.

Does everything now work as expected?

Can you check jogging controls? Does left move left, right move right, up move up, and down move down?

Thank you. Now I have ‘orientated my view’ to be as your photo I can see that the jog controls do move as they ‘should’. I am going to try another test piece to make sure I am thinking about it all correctly. Again, thank you.

I have tried to create this simple job shown below.

When I press the rectangular ‘Frame’ tool the laser moves down the Y axis constantly bumping the left frame. It crashes into the bottom of the frame then moves right on the X axis while still trying to move further down the Y axis with the X gantry constantly bumping.

maybe you have misunderstood the positionig of you machine… the long arm is Y and the short is X.
The correct orientation of the machine is in the image @berainlb posted

The work area in this picture of LB is wrong: Y=Height=400, X=Width=250.
Correct this in device settings and the machine will work as intended

@killrob is correct on this. Please make this change in Edit->Device Settings.

Additionally, you are using “User Origin” as the Start From mode in Laser window. I suggest you switch to Absolute Coords until you are very familiar with the function of the laser. That may have been what caused the crash you had earlier.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.