What is wrong with new 1.0 version (MacOS Big Sur / Ruida)

He doesn’t actually tell me the mistake. When I cut a group of elements, the air pump turns on, as when it starts cutting but does not move. Then I have to press stop to turn off the laser. I have a Chinese laser (Ruida) and all previous versions worked great for me. What I have noticed so far is that if I cut 20 elements, it refuses to cut, but if I specify only 10, it cuts them. What is it?

1 Like

Do you have all the shapes grouped together? Also, what is the origin type you are using?

I tried as a group or I just circled them individually, in both cases it doesn’t work.

Hey Bojan,

I have noticed from your screenshot that you seem to be a Mac user? If that is the case, have you seen the following post with similar issues:

Good luck and cheers,

1 Like

As a test I would suggest you turn on the “Use Selection Origin” and change start from: to “Absolute Coords”

Then position your group of shape on the the worksurface in LightBurn. Then leave the door open on your laser so it does not turn the laser on and start the job to see if the laser head moves correctly.

Also click the preview button to be sure the preview shows the shapes you are cutting.

@BojanR I’m sorry you are having issues with the new version. As noted by @BrianF84 there have been a small subset of Mac users, with Ruida, connected over USB that have had some trouble with the latest release and we are working hard to sort that out quickly. Given how you describe the issue it sounds like you are having the same problem.

Since you have an urgent need to get this work done, I highly recommend simply downloading the previous release again and using that while we sort things out.
You can find the Mac release here:


Alternatively, you can switch to using an ethernet connection instead of USB, which has not presented with the same issues.

1 Like

Thank you all very much for your help. I only have two more questions; whether this revision of the program will come as a new version or otherwise and another question; where can i get the old version. Thanks again. Have a nice day

Sorry l found link to previus version

I’m not sure what you mean here. Do you mean if the fix will be a new version number? If so, yes. It will likely be v1.0.1 or v1.0.2 (depending on how long it takes to fix).

Which version of MacOS are you using? (If you’re not sure, click the ‘Apple’ menu, then ‘About this Mac’)

Mac OS Big Sur v.11.4

1 Like

Can you try this version?

Not working! Same problem with cuting multiple object.

@BojanR - I’ve posted another fix here, and I’m hoping this time I have it:

1 Like

I have the same problem. Also Mac OS Big Sur. Downgrading is the only thing that helps…
And i have a second problem. The speed and power that i enter in lightburn ist’t used by the machine. It only uses the speed and power that i enter on the machine itself. (Ruida machine)

Sorry, but still not working

Do you have the ‘Default’ toggles enabled in the Cut Settings window?


1 Like

Another update posted - we may finally know what the heck is happening here:

A post was merged into an existing topic: Version 1.0 - MacOS issues with Ruida