What should Z-Axis Controller settings be for Ruida 6442S-B? New Bodor 1309 Laser with Autofocus


(John Stevenson) #1

The first time I tried to use Lightburn when I would start a cut, it would move the Z bed down way out of focus before starting to try cutting.
I got this to stop doing it by turning everything off, but I am not sure if this is what I should really be doing to have full use of Lightburn’s abilities.
I do not use the autofocus all the time, especially when I am doing a soft material. This could crash things.
I am also not sure what Lightburn and Ruida can do together and actually use the Z axis during parts making? Can Z move up and down during cutting/scanning etc… I have not gotten that far.

Also, my Z axis does not home on startup (By design I believe)…If that makes some difference.


(Rick James) #2

Have a read here for understanding Z-Axis control within LightBurn.

https://github.com/LightBurnSoftware/Documentation/blob/master/DeviceSettings.md#z-axis-controls


(John Stevenson) #3

I did read all of that and also many others posts on the issues before posting, but I do admit I still have more to learn. I was hoping for more of a best exact settings for my particular machine. I am sure I can figure that out with some experimenting I guess.

What exactly can Lightburn do with this ability?
Enable Z Axis: turn this on to allow LightBurn to control the Z axis of your machine, IE the height of the laser above the workpiece.
Does this just mean the arrow buttons on the computer screen will let you move it manually and it will just continually output the same height of Z in a job, or does this mean it can actually move Z up and down during the job to be able to do things? If the latter, what things? Keep in mind I am very new to laser cutting, so I am still experimenting with all the different things you can do.
Does this option actually allow you to do anything “cool” over just keeping Z off?

When I tried my first Lightburn test job I was not expecting the Z to move down at the start of the job after I had focused it. This is what led me to start looking into this. Good thing it did not move up, or that could have been bad.

Now that I can actually be at my machine I just checked and when my machine boots up, it gives Z the value of 3000 no matter where the bed is when you powered it down. There is no homing of Z in the boot up (which I did know). It does have an inductive limit switch, but it is at the bottom of the table travel. There does not seem to be any limit at the top. This seems like it could be a problem…

Z will stop moving up if the autofocus pin switch is hit. However with no material on the bed or something soft, this could crash if something decided it wanted to make the Z move up because something was done or set wrong with the software.

I have to do some more reading and learning, but this configurations seems easy to crash things on accident. It seems like your machine should at least know where the autofocus pin would not hit the knife or honeycomb table on any X,Y moves. I know having material on there is not considered, and that also actually actuating the autofocus has to let it move into an area where it would snag the bed if you moved X,Y at the top.

Is there anything I should change about my actual machine or controller settings, or is this just the way it is and pretty much the norm (seems like it is)?

Edit I Just tried having Enable Z Axis on and Relative Z moves only on.
This appears to save whatever Z is at when it moves the file to the laser. This seems to show that if you reboot, it is going to try to move Z to that same Z value even though your machine has now actually set itself to 3000 in what could very easily not be where the 3000 was on last boot up. I can see how this is pretty unpredictable. These options do not seem to be safe to me? It would be very easy to crash on accident when it moves to whatever value Z was showing when you transferred the file.
I was thinking relative mode was just going to tell it to take whatever Z is really at when you start the job and use that for relative positioning from that number and location.


(Isaac Barbary) #4

The auto-focus probe is the limit at the top.

Yes, without material on the knife bed, you could crash the bed into the gantry. This is a pretty standard configuration. You just have to be careful.


(Isaac Barbary) #5

Yes, it will give an arbitrary value until the auto-focus routine is run. The auto focus sets the z-axis zero. The reason the z-axis isn’t zeroed at start up is that the zero point changes depending on the height of the material you are working with. Once you place the material on the bed, you should run the auto focus or set the focus manually. Either way is fine.

This could be due to a misconfiguration in the Ruida controller although I would think Bodor would have set that up correctly before sending your unit out.


(Oz) #6

You’re correct, and this is why Z control is disabled by default. The Ruida controller doesn’t have the ability to send it relative Z moves during a job, only absolute Z values, so this is the best option I’ve come up with. You can set the “Material (mm)” setting on the main display to the exact Z height you want the job to start at, and turn off the “relative Z moves” option, but then using auto-focus is a hassle, because you’d need to re-populate this field manually every time you changed material thickness.

Having Z control enabled just means that LightBurn will send Z moves during a job. The Z up/down jogging buttons will work regardless of the Z enable setting. Controlling the Z during a job allows you to do things like shift your focus point to defocus a line, for example, to make it thicker, or push the focus point into the material a little with each pass on a multi-pass cut for thick materials. The former is useful for CO2 machines, the latter is more useful for diode systems.


(Isaac Barbary) #7

You mention you are new to laser cutters, my recommendation is to leave the z-axis disabled in Lightburn until you are more familiar with the lasering process. Either use auto focus or set the focus manually for now. Most of what you do likely won’t benefit from programmatic control of the z-axis anyway.


(John Stevenson) #8

Okay I have spent the whole night researching this and running tests. It seems others have had the same issue, but in many cases the 14 day post timed out and that was the end of the conversation. I did gather some of this from other posts here and my testing. Please correct me if I am wrong in any of this.

Something like this should be in the manual along with what is already in there (maybe just specifically with Ruida setups):

  • With Z disabled, no Z moves are ever emitted, with the exception of the Z jogging buttons in the move panel and the Focus Z button will still work.

  • With Z enabled, relative mode off, the “Material (mm)” setting is the baseline height for the job. Your Z will move to that height initially, and other moves will be based on that. This is an absolute move and will go to the Z position that is the same thickness of your material (10mm material will move to Z=10). If the Z of your machine was not homed or set to the focal point and zeroed, then this may crash your machine because it is going to try to move to z=material thickness. For example: If your material thickness is set to 5mm, and your machine thinks it is at 0 and focused, then you can expect the Z to try to move up 5mm at the beginning of the job (table down). This would be proper and probably what you intended. Now if you did not zero the machine, or you turned it on and it just defaults to something other than where it might really be, such as Z=3000 or something else, then you can expect the machine to try to move 2995mm or whatever it takes to move it to Z=Material thickness when you start the job! You can see how this can cause a crash. If your going to use this method you just have to make sure every time that your nozzle is right where you want Z=0 to be and it should say Z=0 on your control panel before you move the file to the controller. Then it will move to Z=material thickness at the start of the job, or you can leave material thickness at zero and it will not move from Z=0.

  • With Z enabled, relative mode on, the “Material (mm)” setting is ignored and the current machine height is read from the controller and used instead, unless it cannot be read, in which case it falls back to the Material (mm) setting with a warning. If you do not move Z (the nozzle) to where you really want Z=0 to be BEFORE you transfer the file, this can result in a crash. This method assumes you have physically moved your Z where you want it to start the job and set your focus (or wherever you intend Z to be) BEFORE you transfer the file. The Z value shown on the machine controller does not matter as long as the nozzle is where you want it to be seen as “zero”. Whatever Lightburn sees as Z read from your machine will essentially be compensated for in the software to make it 0 in the code. Since Ruida cannot do relative, it always moves to an absolute position. This means if you did not have your machine focused before you move the file from your computer to the controller, then your job will try to move it to the corrected absolute value which will not be corrected properly because you did not set the laser nozzle where you really want it to be seen as “zero”.
    Note: RDWorks and Ruida Controller are not designed to move Z for any cut or scan operations. If you want to make Lightburn work the same and not risk the crashes to gain access to Z moves that Lightburn can do, then you need to just pick Z disabled! Lightburn has extra abilities, but you must heed the extra precautions above or possibly crash your machine.

With that said, I think I understand how this works, but what I cannot figure out is how to set Z=0 on my Ruida once I have the nozzle where I want it unless I actually let it run the autofocus. Autofocus cannot be used in certain scenarios (soft materials etc). I am still researching this.

Another problem I forsee is that if you use the Relative Z mode, then you cannot run that job from the controller next time you power up the laser cutter. The new Z=3000 will not be in the same place as it was last time if the bed has been moved…You would have to move the file over from the computer each run with the Z where you want it on the machine…correct? This is why I think not using the relative mode and just making it a practice to always zero Z before every job would be best, but at this point I see no way to zero Z without running an probe :frowning:


(John Stevenson) #9

The first time I tried, It moved on me because I set the focus AFTER the file was moved over and I had Lightburn set to Z on and Z Relative. This makes sense now, but this is confusing to figure out. I think it would be helpful to have more text and clarification in the manual on this one. I will certainly forget this and forget to do it the right way if I go away from my laser for a long period.
Sorry I was typing that long response while you guys were answering…


(Isaac Barbary) #10

Pretty sure that is the only way. If there is another, I am not aware of it.

Where there’s a will there’s a way.


(system) closed #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.