When trying to use the “Fill” option it says cut out of bounds or over scanning!


I hope I can get some help or someone shine some light on my situation. I have a xtool D1 pro with a laser tree k60. The laser works fine on the XCS. The issue is when I got to light burn and use Fill. It’s gives me a overscanning or cut out of bounds. I used the same design (a circle) on XCS and light burn but lightburn gives me the problem. When I press the start button the laser moves very slowly to the bottom left corner. My home positions is too left and it homes perfectly fine. Also the projected time goes into negative numbers. I just got the K60 works good on XCS but I would like to use light burn. Please help!

I’d like to confirm that I’m understanding you correctly. You’re using a xtool D1 pro with a laser tree k60 mounted to it? Can you attach a screenshot of LightBurn when you receive the overscanning/out of bounds warnings? It’s possible that your design is too close to the edge of your workspace and you aren’t giving your laser enough room to engrave an image with your current overscan settings.

In regard to the time, are you referring to the estimate from your preview window in LightBurn? Because the time bar in your laser tab is is a freestanding counter between the states of your controller/LightBurn.

1 Like

There are two modes a machine can use, one is vector, the other scan.

A vector is just a tool path the laser head will follow. If you do very small vectors it my never reach the requested speed if the head doesn’t have enough distance or acceleration to achieve that speed. Nothing will advise you of this, it’s just part of learning how they work…

Once you switch to fill mode, it acts like a printer, scanning each line side to side. It will ensure your speed is what’s requested by slowing, changing directions and speeding back up, all outside the lasing graphics.

You can have the graphic too close to the edge as @JessN mentioned or you could just have the requested speed too high for it to perform as requested. This is known as overscan.

You can see the effect of overscan using the preview, in Lightburn. Enable show transversal moves will show, in red, where the head will travel.

Both rectangles are the same size… The one on the right is set for 500mm/s speed and you can see where the head travels outside of the rectangle to get to speed. This takes <4 minutes to execute the job.

On the left, the speed is now 1000mm/s, same size rectangle, but the overscan exceeds the actual workspace (green outline). Even though you can reach higher speeds you’ll notice it takes almost twice as long to run at ~7 minutes at twice the speed.

The left one will giver you an out of bounds error.

Does this make sense?



@JessN Yes, I do have a xtool d1 with a laser tree k60 mounted. This set up works fine one XCS, also does well with light burn until I do the fill mode. Please see attached for over scanning

Yes makes sense but I tried adjusting the Over scanning setting and I still get that pop up and when I press continue the laser moves slowly to the bottom left corner. not engraving no laser is fired just jogs over to that bottom left corner

Could you have Lightburn set to mm and the laser to inches?


Where can I find that option?

Are there any clues in your console window? Does everything look as it should in your preview window? My understanding is that with the xtool d1 pro, the Start From position can only be set to Current Position, which is what you’re using. Are you using the latest lbdev configuration file from their tutorial?

What you describe ‘when I press continue the laser moves slowly to the bottom left corner. not engraving no laser is fired just jogs over to that bottom left corner’

It sounds like the connection was dropped, then reestablished and your laser is auto homing itself to the bottom left corner on startup…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.