When using YRC1.0 chuck rotary, Click-to-Move moves the laser too far

I am having a head-scratcher with my new YRC1.0 and looking for an explanation.

The Click-to-Move button in Lightburn 1.3.01 sends the laser about twice as far as it should, along the Y axis.

This does not seem to be affected by the number I put into Rotary Setup. It frames just fine. The frame is exactly right. I made a rectangle the correct length to do one full rotation of a glass, and when framing, the two ends of the rectangle meet up. But I cannot use the click-to-move tool to move the laser to the four corners of the rectangle. It spins that glass around two full rotations to get from bottom left corner to top left corner (and misses, it’s not exactly double).

Anytime I use the click-to-move tool to move along the Y axis, it goes twice as far as it should, no matter what numbers I put in the rotary setup. I tried 20 mm/rotation, and I tried 500 mm/rotation, just because I wanted to see wildly different results so I could start dialing it in. But it changes nothing, as far as that tool is concerned.

This happens whether the “Enable Rotary” is on or off. This does NOT happen if I plug the Y cable back into the Y stepper. It’s only when the rotary is connected.

The stepper motor in the rotary has the exact same numbers for specifications as the Y motors in the AL2 - it’s a 1.8 degree stepper. If that were wrong, it wouldn’t frame correctly either.

Now, I know that I could just use framing to position my stuff, but I bought this chuck to do some precision stuff, and the click-to-move tool is how I line things up. If I can’t use that to position the laser at precisely the right spot on the design, that’s going to be a problem.

Anyone else having this problem? Any ideas?

Anyone? Bueller?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.