Where's The Fill or The Nodes

I had this made on Fiverr and the guy used AutoCAD to make it. I have always had issues importing svg files into lightburn that’s made in AC. So we been using the dxf format which seem ok. Until now.Can someone tell me why I have no engraving or nodes available.
I cut this out yesterday and it did fair but needed some revisions. It was doing the same yesterday. I only have the line no Fill. Can someone help?

I’m using Mac, xTool D1 Pro

stevens-rev.dxf (453.8 KB)

It’s a mass of disconnected line segments, rather than a set of paths.

A quick fix is to select and join the pieces:

Edit → Select open shapes
Edit → Auto-join selected shapes

Which then looks reasonable:

It has a zillion nodes, but aggressive optimization might beat it into submission:

Edit → Optimize selected shapes

Good hunting!

thanjk you so much. My Fiverr guy seems lost

Pro tip… if the guy you’re hiring is using AutoCAD for illustration work, you might want to go with someone else.

1 Like

I merged your double post below. Please do not post the same question in multiple places. One may think this up’s their odds of getting a faster response. Not so. It generates more work than should be required. :slight_smile:


I had this created in Fiverr and when I import it I cant edit like others. Everything is in hundreds of different segments. The guy used AutoCAD or solidweorks to build it. I’m only using LB. Can anybody offer ideas why this happens or what I can do to fix it,. I only have the line look in LB no Fill. Nothing changes when Itry

The guy that’s created this keeps saying its right but I cvan’t do anything with it.,

stevens1.dxf (440.1 KB)

I opened it and it all looks fine. Filled no problem.

Do you by chance have a non-zero auto-close tolerance for DXF files in Settings?

This shows neither as filled nor as closed for me with auto-close tolerance set to 0.

.002mm for auto-close.

i disnt know I was syppose to have it set like that. I haven’t messed with settings I don’t know. Thank you guys so much

Normally you would never need this setting. It can actually cause odd behaviors at times. I personally would leave it at 0 and repair the shapes using the other techniques listed here including what @Rick has documented. That way you know what you’re dealing with.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.