While etching text on glass, the beginning of letters doesn’t etch

I’m using a 60w Chinese laser Ruida 644XG. Running Lightburn 1.0.06. 450 mm/s, max power 45, min power 45, 0.050mm interval. I’ve also tried at 500mm/s from 40% to 80% and it does the same thing.

I don’t understand why it looks like it etched there just not at the same power as everywhere else.

Any advise you guys could share, or if I missed any settings that could help y’all assist me in troubleshooting this issue.

Thank you in advance!


Could the rotary itself be moved during the run.

If I look closely at the first you can see the drop off line, in multiple places.

In the red circles it almost looks ‘doubled’ or that it slipped on the rotary.

The red lines are the repeated ‘change’ in the damage to the glass.

The green was something I can see and seems like it’s also from the slippage…

It’s almost like the rotary has moved and the focus has changed.

I’ll have to think on this one…

Might post the Y axes minimum speed, can’t remember what it’s called exactly, but it how fast it will move the Y axes to start. I have mine set around 5, I think. I’m working on the theory that it’s slipping.

Still thinking about how the laser could have a problem like that…

Good luck.


Thank you for your help. That’s my fault, when taking the picture the backside of the glass acts as a mirror and makes the image look doubled. I retook the picture so you can see more clearly. I don’t think it’s slipping, because the image is still there and accurate, it’s just faint. And in some area like the one circled in green at some point on that pass it etched properly. Then when it gets to a certain part of the letter it just stops. I’ve also added pictures of my machine settings.

I’d like to confirm you are scanning in a vertical direction, relative to the pictures?

You’re Y axes speeds are greater than mine, but that should not influence the laser firing. Since min and max are equal, the ‘start speed’ shouldn’t be an issue either.

I don’t run must faster than about 200 to 300mm/s for glass or mirrors, have you tried to slow it down?


Can you show us your actual rotary setup with the glass sitting in the assembly?

I’ll try slowing it down, what power percentage do you use at those speeds?

The rotary is DIY from a video I found on YouTube. It’s not pretty but it works better than the one with metal rollers that came with the machine.

Here’s a picture of my setup:

1 Like

Were you using flood fill for this? Can you show a screenshot of the preview? I’m guessing that it’s accelerating too quickly when it’s changing direction.

You may want to try a simple fill where it’s going the full length left and right for every row.

No that was the first thing I checked, I’ve made that mistake of leaving flood fill on. Flood fill is off and I have it set to fill all shapes at once, it should engrave everything in one pass moving up one line etching in both directions.

Shoot. What made me think that is because it’s literally only those tails that are affected. Other parts above and below on the same line look fine.

I feel like this has to be some sort of power modulation issue in that case. But couldn’t tell you what or how.

Do the artifacts change with speed?

I won’t get a chance to try until tomorrow but I’m going to try at 200 and 300 mm/s, if any one could suggest some power ranges at those speeds I would appreciate it.

I looked at my mirror stuff, the machine is asleep, so I can’t look at the setup when the rotary is in use.

My mirror is set for 2" lens, 120mm/s @ 13/9.3. This was for taking off the mirror backing, but it was engraving well at that setting. A bit slow it seems, but… Make it a ‘small’ area test so you don’t waste material…

The arrow indicates a bump in power from 13 to 18.

Good luck, let us know how you make out…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.