Why can't I move the green square?

Hi, Below represents a low power cut I’m trying to make on a board that contains a mounted potentiometer.
So the circle represents the center of the potentiometer. I have a long lens that it won’t hit the stem of the pot.

I’d like to put the graphics squarely around the pot i.e. center that green square in the center of the circle.
I’d like to then set origin on the center of that pot on my laser. Using tape, laser glasses and the test button.
I’d like to not mess with controller settings and the little I tried nothing seemed to matter.
I hope is not some limitation in my controller. :grinning:

The origin seems to auto generate based on vector graphics around it.
So remove the words on top and it gets more center.
Add more spokes and numbers and better yet…but I don’t want to adjust the vectors in order to true this up.
‘Start here’ doesn’t help align the vector engraving with the actual part.

I’m sure this has been covered before but can only find discussion, not a real solution.
Does anyone have a link handy or can explain the solution?
Thanks, Dean

green square

Draw a circle using a tool layer (T1 or T2) and enable the ‘Frame’ toggle on it. Make that circle surround your whole design, and center it on the middle circle.

You can’t manually move the green square because of the way some DSP controllers work and expect the positioning to behave. Your ‘Depth Target’ text is pulling the center up and to the right.

Ok so I put more stuff on a different layer and that does move the green square. however Id rather not transmit that layer. If I turn off that layer then and transmit to my controller result is that it shows the original location for the green square (as shown in my image) but Lightburn shows it perfectly centered. I’m looking at the image in the controller. I didn’t take a cut but believe that it would cut off-center to origin on my machine. Looked promising.
sorry to be a pain.

So I dusted off a copy of Raycam (Its a Lightobject version of some popular program). Profile shows my controller.
put the design in and same thing happened - origin off center both Raycam and my controller
Took a cut and yes its off center.
then tried your trick and added a different layer and a large oval and I could pull the origin to center.
then disabled the output of that second graphic. Everything stayed in center same as LB
Transmitted it and shows it to be in center on my controller. with LB my controller was off center.
took a cut and the cut is centered around test file and origin. the added vector was not cut. I didn’t test cut the LB transmit but it was clearly off center in the controller.

So I was able to use your trick on my original laser software but not lightburn. didn’t touch settings in the controller. tried it twice and it repeated. Lightburn seems to be not affected by that second layer if you don’t transmit it, however Raycam factors it in even though the output is turned off. Weird?

Is there some setting in LIghtburn that can can be adjusted?
This is not a huge issue and I learned a lot just messing with it.

I specifically mentioned using a Tool Layer because those are never sent to the laser. Like this:

1 Like

I tried the above method using the special tool layer and it shows it centered In LB, but when transmitted to the controller it was off center. So I took the cut anyway and it cuts on center. Success!

Also again tried to turn the output off on a normal cut layer and pretty much the same thing happened.
Both times the controller shows it off center but it cuts on center (to controller origin).
Thanks

Can you elaborate on what you mean by “the controller shows it off center”? Is it framing wrong?

this is the controller view of the centered vector from Lightburn.

and this is the engrave. this is my long lens which isn’t great for engraving.
the dot in the center is a test fire at the machine origin.

I thought the blue mark on the controller is location of origin, but apparently not in this case.

Hmm - I thought so too - they might be computing that from the actual content of the job itself, instead of using the bounds info that we send, but I’m happy that it did the correct thing in the end.