Why no snap to grid?

In settings I have Snap to Grid enabled and the Grid Snap Distance at 1.00, yet when I draw a rectangle it doesn’t land on the grid but just wherever I land my pointer. This has me halted before I even begin. What gives? Thank you.

Here are a few resources to help explain ‘Snap’ behavior. Review these and let us know if you are still having issues. Please include the LightBurn version and the OS and OS version you are working with.

https://lightburnsoftware.github.io/NewDocs/CreationTools.html#snapping

https://lightburnsoftware.github.io/NewDocs/TipsAndTricks.html#snapping-behaviors

All right, I see this is not an unknown problem. I experimented with snap values. It seems that if I set it to 5, then it snaps if I draw near a grid multiple of 5. If I set it to 4, it snaps if near a multiple of 4. But it does not snap if I am not near a multiple of 4, instead just lands wherever my cursor is. Same experience if I try 3. When I set snap to 1, it’s just unable to snap at all. This is really weird and inconvenient, but I have been tasked with using Lightburn, so I hope for some info that makes sense of this. Thank you.

I wrote my reply before I saw yours. I’ll go through those links. Thank you.

Here is a clip of me snapping when drawing a rectangle. Snaps to the 1mm grid points. This is not working for you?

2020-08-31_13-34-32 (1)

No. Here’s the Settings window.

OK, and here is mine running LightBurn 9.16 on a Mac running OSX 10.13.6 (17G14019) and is what I had set when showing the snap behavior working as expected.

What don’t we know about your setup?

image

image

The snapping behavior is not “only snap”, it’s “strongly prefer” - if you are zoomed in, it will allow you to draw in locations that aren’t on the grid if your cursor is far enough in screen distance away from those points, but it will (or should) snap when you get closer to one. Could this explain what you’re seeing?

I zoomed out so the drawing area was 100mm wide. I then did see the 1mm snap a couple times. I then tried to draw off the 1mm grid while zoomed out that far and was able to. Maybe I just need to turn off the “strongly prefer” so that it is strict about grids. Is that possible?

(My opinion, the ability to draw off-grid while snap to grid is enabled has no utility. I may often need to zoom in so that I can clearly see what I am doing while ensuring everything is on the snap grid I’ve specified. Only one person’s opinion however.)

Attempting to move the side of a rectangle, I wanted it to be on a 5mm grid, but found that no matter how far I zoom out, it ends up where the cursor is and not on the 5mm grid (which I had set snap to).

I can’t spend a lot of time debugging software, nts, so I need to know how to bring up object properties so I can edit them directly (specify coordinates). I may find this before you have a chance to reply, just saying.

OK, I’ll figure it out. If I zoom out real far I can use snap to grid as part of the correction for not having had it while zoomed in. Thank you for attending to this issue.

It was incredibly awkward to work with when it was set that way, which is why it was changed. Since the snapping behavior is on by default, anyone new to the software, zooming in and working with node editing was finding the nodes “jumped” all over the place (because they were zoomed in more than their grid spacing).

If you are “moving one side” you’re not moving, you’re scaling, and that behaves differently - it doesn’t snap at this point. You cannot directly edit the coordinates of points of a shape, but you can edit size and position easily with the number bar at the top.

I would say start with the new documentation walkthrough as it covers most of this:
https://lightburnsoftware.github.io/NewDocs/BeginnerWalkthrough.html

While doing that, keep in mind that LightBurn was intended to be laser control software with light editing facilities, not a full featured creation / CAD package, though it is progressing somewhat in that direction now.

Yes, I remembered after all this that I always have the option of importing from another package. That said, so far Lightburn is miles ahead of other laser control software I’ve used in terms of its drafting capabilities. Thanks again. I’m well past that first hurdle at any rate.