Wifi camera shows up on OBS app but when I select it in Lightburn, its just a blank rectangle

so I have usb camera on RPI using cam2ip. works great. OBS on my PC shows the laser bed no problem. Open Lightburn, select the OBS Virtual Camera… get a nice perfect black rectangle. anyone have a fix? (Windows 10 updated).

thank you all in advance for your help. so close… yet so far LOL

Check Windows permission to confirm that LightBurn has access to camera and microphone.

1 Like

So it finds the usb camera when plugged directly into the machine… would Lightburn have permission for that but not the virtual OBS camera?

I’m assuming it’s setup as a discrete device type. And not all cameras require microphone permission to be accessible for those to work in LightBurn so worth checking.

The other thing you may want to check to see if it makes a difference is to change the “Camera Capture System” in Edit->Settings from Custom to Default.

Appreciate your reply. Checked permissions, lightburn software is listed under desktop apps. Everything seems to be permissioned for access. Lightburn set for default vs custom. (Tried it both ways). Still all I get is that darned blank image.

I was like 9/10s of the way there and now I’m stumped. Frustrating indeed.

And to confirm, you did this for both camera and microphone?

verified Lightburn is listed under camera but is not listed under microphone… however OBS listed under mic and shows last accessed today. I do not see how to add Lightburn to the list…

Did you enable the toggle for “Let desktop apps access your microphone”?

If so, that should be sufficient. I’m thinking that if LightBurn is not listed there that it’s never attempted to access the microphone.

Yup…. And the only desktop app that is relevant is the OBS which is there.

But no Lightburn.

Hmm… running out of ideas. Is it possible that OBS is somehow tying-up the camera? Perhaps try shutting down OBS and any background processes.

Its been a while since I have worked with the OBS Virtual Camera, but I seem to recall that you need to enable/start the virtual camera in OBS to allow video to actually start streaming to the apps that are accessing it. I could be wrong, but it might be worth checking.

Hi, yup. That is exactly what needs to be done. I start OBS, click ‘start streaming’ and then it streams… on the OBS software, it was always accessible via url, but in Lightburn, it simply blank black rectangle… and when I click on the available camera, (it does show obs virtual camera as available) it pretends to connect, but NO image, i click on overlay and then all the buttons gray out… have to deselect in order to clear it. Very frustrating… i believe it is a lightburn issue as the camera is accessible from everything else i have tried accessing with… including my iphone, ipad, url, obs and other camera apps. One thing to note that in windows, when I click on camera now, it says no camera to be found. I was able in the past to see a webcam when physically plugged into the pc… but that is no longer the case… so if not lightburn, could be the pc itself. But I am completely stumped.

Well, it has been a week and I still have no idea why Lightburn recognizes the virtual camera but only shows a blank screen. From the search on the net, this is not such an uncommon occurrence. What is uncommon is ANY solution.

Other than VirtualHere, any other USB to iP camera ideas out there? Still have not figured out why Lightburn sees the camera but not the image. Frustrating when it works, yet it does not work ‘all the way’. LOL

Man, I went down the rabbit hole on getting this to work. So, what finally fixed it, was downloading the old Virtual Cam drivers from the OBS github, and installing those. Once those are active, LightBurn worked flawlessly after that.

Thanks so much…. I never would have even thought to go there…. I can’t wait to try that out tomorrow. Much obliged

wo what version would you recommend. I had 27.2 and recently installed the newest 28.1