Windows 10, but running Windows 8 in compatibility mode fixed USB camera issues

I didn’t see anyone else talking about having to running LightBurn with Windows compatibility mode, so I figured I would post this here. I had seen a few post talking about issues with camera, but none offered this as a solution.

Version of LightBurn:
Laser: Typical K40 (40Watt CO2), but with the latest 2019 3D Cohesion board running smoothie.

So I’m running Windows 10 on an newer 2018 Asus laptop with a 4k screen.
|OS Name|Microsoft Windows 10 Home|
|Version|10.0.17763 Build 17763|
|System Manufacturer|ASUSTeK COMPUTER INC.|
|System Model|X580VD|
|Processor|Intel® Core™ i7-7700HQ CPU @ 2.80GHz, 2808 Mhz, 4 Core(s), 8 Logical Processor(s)|
|Installed Physical Memory (RAM)| 32.0 GB|
|Resolution|3840 x 2160 x 59 hertz|

I was trying to use this USB camera: ELP-USB500W05G-BL170 is a wide angle fisheye lens 5megapixel usb camera, with aluminum case. Link to Amazon

I also tried another older 720p USB webcam I had sitting around, but the results were the same as the above 5MP. I also tried the build in one on the monitor with similar results.

OK, now that is all out of the way, the problem. I’m very new to LightBurn and it was working for me without any issues, until I added the USB camera. The camera simply would lock up the LightBurn app when ever I tried to select a camera. Didn’t mater it if was selecting it from the “Camera Control” tab or Tools/Calibrate Camera Lens screen. After selecting the different cameras from the drop down lists it would just hang with the title header of the app windows saying unresponsive. I would have to click the X and just kill the app. I tried everything I could think of. Rebooted, plugging in the camera to different USB ports. With and without the Laser connected, disabling all other cameras, etc… But every once in a while it would work, until I closed the app and relaunched. So I tried closing, opening, select camera and see what happened. What happened was once out of 20 or so attempts the first camera you selected would work. So on the rare cases you had the app running and you could use the camera it just worked as expected. Close the app and immediately open it again and back to camera not working.

I tried to run LightBurn on Windows 7 compatibility mode, but that didn’t seem to help. Just as I was about to give up I ran Microsoft’s troubleshooter on the LightBurn app icon. It suggested Windows 8 compatibility mode, so I was like sure what ever. That was it… all camera’s worked every time I would launch LightBurn. I closed it many times, open it back up, select a camera, then a second camera. It worked just like you would expect every time for all the Cameras, in Control tab and the camera calibration screens.

I’m not sure why that worked, but I didn’t really see anyone on the forum talk about having to do this with cameras, so I figured I would share my experience in case it helps someone else. Maybe if the camera doesn’t seem to be working on Windows 10, try running it in Window 8 compatibility mode.

1 Like

That is bizarre, but thank you - that might help some others.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.