Windows 11 + USB + Lightburn + Ruida 6445G

Any known issues with this combination? I can’t seem to get my new windows 11 laptop to see my laser. Old one (windows 10) works fine. FTDI Drivers were installed along with lightburn.

I don’t believe there’s any inherent issue with that combination. Plenty of folks on the forum use that setup.

1 Like

k I might need some help then lol

I finally found some hint that it’s detecting a USB device in Control Panel → Devices and printers. I show a “ft245r usb fifo” device there with the only option as “remove”. This is definitely the laser, it comes and goes when I plug and unplug it. I tried removing it then reinstalling lightburn + driver and still no go.

I can’t find anything in the device manager for it. It’s not assigning it a COM port.

I’m at a bit of a loss

How are you installing the driver?

Can you take a screenshot of Device Manager showing the device?

I’m installing it from the last prompt lightburn’s installer gives

I can’t find anything in the Device Manager. Just what’s in the screenshot from elsewhere in the control panel (bluetooth & devices I think). Odd spot for it, but its definitely what is being picked up when my laser is plugged in.

The “FT245R USB FIFO” device in the screenshot I meant

Can you open Device Manager and check for any “Other devices”?

Nothing there/not a category

Try this:

  1. download new driver in executable form from FTDI site:
  2. Unzip and execute file

You should get a status with green check marks if everything is good to go. At that point you should have a USB Serial device.

If that’s the case, then test LightBurn again.

lol apologies, actually already tried that.
I also tried their removal utility, then reinstalling again.
I was doing some poking around and found a thread about that and figured it was worth a go.

I’m open for more suggestions! Worst case I might get it set up via ethernet if we can’t figure out the USB problem. I’m convinced I have some kind of driver conflict going on but for the life of me I can’t find and remove anything that seems to be making a difference


If Ethernet is an option that has its own advantages.

If you want to continue pursuing the USB path I suggest you traverse through Device Manager until you find the device. It may be listed under USB somewhere.

You might try loading the USB driver from the RDWorks install. You can install just the USB drivers without loading the program.

I’ll try this over the weekend before I switch to ethernet (some logistical hassles with that option). Great idea, thanks!

I had intermittent problems with the network connection, even though it’s a hard set address, not DHCP. Don’t know why, and my design computer is no where near the laser, so I just loaded the laser software on an old laptop and set it next to the laser. Transfer the file and run it from there.

That actually worked. It took me a while to find a working download of RDWorks 8.01.60, though I doubt having the newest version mattered much.

Once I ran its installer a window popped up with buttons/options. One of those was to install the driver. It gave a prompt to plug the laser in first, then install. Plugging it in first was important, I ran it once without just to see what it’d do and it didn’t work. I’m curious if I had it plugged in when I installed lightburn if it would have worked from the start. No clue if lightburn prompts for that and I just missed it, or if its necessary, or would have helped my situation.

Thank you guys

Not sure what USB installer LightBurn uses, but the factory Ruida installer looks for the controller and then installs the correct USB driver for what response it gets back. I do know they are not generic USB drivers that come with Windows, Ruida claims them to be a proprietary driver. But that cold just be salesmen talking.

Guess I should have told you I have several versions at the top of my Google Mod page in folders.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.