Windows driver update disconnected Lightburn from laser (LAN)

Due to issues with my Wi-Fi, I chose to let Dell upgrade all of my drivers on my computer. Post this update, I no longer can get Lightburn to send data to my laser. A few things I did:

  1. I re-verified that the Ruida controller had an appropriate IP address.
  2. I pinged the controller from my laptop with success (meaning that they talk) Note, the LAN was listed as ON on the controller screen
  3. I re-booted my computer and laser
  4. I reinstalled the most recent version of Lightburn
  5. I looked for updated drivers for the KT332N online, and could not find a location

Even after all that, Lightburn stated that the controller is Disconnected. Reading some of the other forums, I sent a frame command and a print command, both times it stated that the controller was busy and could not receive data.

I suspect that this is a driver upgrade issue, but any help is appreciated.

Unless your networking is not working at all I tend to think this is not a driver issue. No Ruida specific driver is being used in a network scenario, only what’s used for standard networking.

What issues with WiFi were you experiencing?

Can you describe the network topology that your Ruida and computer live in?

What are the addresses for your computer and Ruida?

First thing I’d look at is to disable firewall or any antivirus software (especially end-point protection) to see if that makes a difference.

So the issue with the Wi-Fi was that the computer kept disconnecting and the hardware had an error. This seems to be corrected.

The computer is direct-connected to the controller via a cross-over cable using 169.254 … address

  • computer uses, Ruida controller is on

Windows firewall is disabled due to being on Norton

Norton has been on the computer for years, and only deals with public networks.

On a side note, looking to assign an older computer to be my laser controller while I figure this out.

Thanks for the quick reply.

Is it possible that your network settings have changed with the WiFi update? For some reason you have communication failing from LB to your controller. Probably worth checking this.

Does this mean you’re relying on Windows timeout to assign a private IP?

Can you confirm you configured the Ruida IP manually?

Can you run this from a command prompt in Windows?

route print 169.254.*

Are you able to test if behavior is different in RDWorks?

Haven’t needed these since the 90’s… :crazy_face:

In the Laser window of Lightburn, does it say ‘disconnected’ or ‘ready’ at the top of that window?

I’m making an assumption that this has always worked via the direct Ethernet connection…?

If so, I would assume the Wifi issues is unrelated.?

Have you set your Ethernet port on Windows for the correct IP address?

If this has worked I wouldn’t fool with the Ruida at this point.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.