Won't burn centered in tool layer

I have created a jig and a matching template to burn items such as keychains. When I center the graphic or words in the template (within a tool layer) it appears to be centered on screen but consistently burns 3mm or so left and 1-2 mm high on the actual jig. It is consistent and repeatable, the laser will always burn off center in the same area for each design.

Using the on-screen template, I can move the laser to the corners of the designated cutout on the jig and everything lines up perfect. If I change the tool layer to a working layer on the template and burn that as well as the graphics within everything is centered as it should be. I have tried changing the tool layers to working layers and just turning off output but I get the same off-center results.

I made a short video but I’m not sure if or how to put it up on here.

To clarify, I’m using absolute coordinates.

If it’s a very short < 4mb, you can probably just drag and drop it on the reply window and the system will upload it. You can also use the upload icondownload-icon-backgroundon the tool bar.

You can put it somewhere like a Google drive and just post the link here. Make sure you set the video link so anyone with the link can read it.

Do you make your template using absolute coordinates?


Yes, my templates are made using absolute coordinates. Usually, I burn the jig using the template then just turn everything into a tool layer for later use. I tried a onedrive link…lets see if it works.

So, for the sake of eliminating anything that may inadvertently be causing an issue, I uninstalled light burn from the laptop reinstalled it. I then did away with the template and jig and using absolute coordinates cut another rectangle in new material. I then turned that into a tool layer and centered another rectangle within the one that was just cut. I am experiencing the exact same results; in light burn, the layer to be cut is perfectly centered in the tool layer. The newly created jig lines up perfectly because it was just cut using what’s on the work area and light burn.

Even though the rectangle shows as perfectly centered, it is burning about two and a half millimeters left and a millimeter or so high. In a large project, this probably wouldn’t be noticeable, but in burning keychains it’s enough to make the design almost go over the edge.

I can’t think of anything off hand, maybe one of the others that more up on the grbl machines can help…

Maybe @berainlb has something up his sleeve you can try and determine the issue.

I’ve done this on all my machines except the fiber…


I appreciate the attempt nevertheless… Were you able to look at the short video I posted a link too? I hope I’m making the problem clear without muddying the waters too much, lol.

This is an interesting situation.

Could you run a few tests:

  1. Disable pointer offset in Edit->Device Settings. Then get your goggles on and enable the Fire button in Move window and repeat the corners test that you performed in the video. Are the results the same?
  2. Set 9-dots setting in Numeric Edits toolbar to top-left. Then click on the tool layer box. What is the numeric position in toolbar?
    Repeat for internal box.
    Then in Move window enter those coordinates in Go to field. Where does the laser locate for each coordinate?

I have tried to disable pointer offset and it doesn’t affect anything. I had a user from a Facebook group suggest I move the work in lightburn to properly line up with the laser vs crosshairs since lightburn won’t do it. I did this and the centering seems much more acceptable now when using a template/jig combo. I’m still quite perplexed of A) why or how this affects centering B) why I can’t turn off laser offset (well, I can physically turn the button off, but it doesn’t do anything).

I am a laser rookie and you lost me on the second request. I’m not sure what you’re asking me to do. I don’t know what numeric edits tool bar is,

Not affecting anything would be highly unusual. It may just be that it’s affecting it in a way that’s not obvious to you.

With the offset enabled, when burning the blue diode position will shift 16 mm to the left to match the position of the red crosshairs. With the offset disabled, this shift should not occur. So wherever the blue laser points to during framing is where it will burn.

Read through this section of the LightBurn docs and hopefully this makes more sense:

I stand corrected. I was using the buttons on the move tab and absolute coordinates, so I did not see a shift take place. I changed it to current position and played with framing a square and do in fact see the on/off making a difference.

Nevertheless, I am still unable to figure out why my template in lightburn lines up with my jig but will not properly center the items in the template in the cutouts on the jig. I have not messed with it extensively, but it seems that if I turn off laser offset and move the template to that I am framing with the laser instead of crosshairs, the centering is much more accurate, not dead on, but certainly tolerable. Why do the tool layers line up perfectly with the jig but the centered items within will not burn centered (see above video link)?

This is what I was hoping to understand better based on the two tests I specified.

With running your same tests using the primary laser instead of the offset, are the results the same or different? Meaning when you request the laser to move to the corner of each rectangle do they match the incorrect location as shown in the video or does it now go to the correct location.

The offset shouldn’t affect this but I just want to rule out that there may be something going on with that.

For the second test I want to understand if there’s a disconnect between workspace location vs physical location or if something else might be going on.

Ok, here is what you’re asking for. When the laser off set is on and off, if I move the laser to the corner of the rectangle in the tool layer the cross hairs will move to the designated corner, with both settings. I didn’t mean to, but I also learned the rectangle will burn in the designated location as well as with the off set, depending on whether on or off…oops.

As far as the coordinates, everything lines up properly. But I anticipated this as everything lines up in the template and jig. For instance, as in the video, if I move the laser to the corner of the rectangle in the template it moves to the corner on the jig. If I move it to the corner of the second rectangle within the tool layer, it moves to the corner. What is confusing is the rectangle in the template is centered, but the one I just burned is off center by 4 mm. But the coordinates still match and the laser can still be moved to the designated location.

It is only the middle or “centered” rectangle that is off and it is always off center to the left and high. If I turn the tool layer into an active layer, it will burn exactly around the edges in the jig…again, an oops, but good to know.

To explain further, it seems if I don’t use the cross hairs and line up the template and jig so the actual laser is hitting in the corner and not the crosshairs, the center rectangle burns much closer to centered. But, this seems like a work around and I’d love to know what I’m doing of Lightburn is doing wrong.

Did you perform the steps listed in the second test? Can you provide specific answers to each of the questions?

Specifically, I’m curious about where the laser ended-up pointing when you manually entered coordinates in Move window.

Yes, I did the test. Specifically, the coordinates to the upper left corner of tool layer were 63.444/42.771 and upper left corner of inner rectangle 71.876/51.044. Yes, when coordinates were entered, the laser moved to the appropriate location on the jig for both. Same results as before, the smaller rectangle showing centered on screen but being close to 4mm left in reality.

Something I had not tried before was using current position. Without changing anything with the jig or template I switched laser positioning to current position and manually moved the laser to the upper left corner in the jig cutout. It then burned the center rectangle pretty much centered (less than 1mm variance which I could certainly attribute to human error and manually positioning and lining up). So the question remains the same, why does the laser know where the jig cut out rectangle is with precision but can’t center within using absolute coordinates? Being able to frame the tool layer accurately negates the thought of the laser not being home properly or knowing where home is I would think.

I interpret “appropriate location” to mean same as before, but not where you expect. Please correct me if that’s the case.

This is increasingly odd. I’m not able to build a mental model for what’s going on in your setup.

Can you post the .lbrn file that you’re working from?

Sorry, don’t mean to be confusing. What I meant by appropriate location was when coordinates were entered, the laser moved to the designated corner of the jig cutout. When the coordinates were entered for the smaller rectangle, that should be centered, it moved the laser to the exact corner of the rectangle that was burned within the template. So, everything matched/lined up with lightburn.

The question remains what is centered on screen is not centered when burned even though the actual jig cutout directly correlates/matches/lines up with the template on screen. I used the measurement tool within lightburn to ensure the smaller rectangle was in fact centered on screen and it is.

The attached file is the jig template without any centered test rectangles. I haven’t saved any of those, it doesn’t matter the size or which jig cutout I use, the inner burned rectangle is always left and high.
7 dog tag keychain.lbrn2 (10.4 KB)

It’s not obvious to me what’s happening.

Perhaps try running some tests:

  1. create x marks or other shapes at 10 mm square intervals so you end up with a grid of x marks
  2. burn the x marks
  3. Using Arrange->Move laser to selection->Move laser to selection center check that you can relocate every x in workspace to the correlating position on the previously burned positioned.

I’m not sure what you’re not understanding, I don’t know how to explain it any different and I posted a short video above showing what is happening. I don’t really see the benefit of doing that test, as things are not the same on the lightburn work area as they are burning in the laser. As I said earlier, a design will be centered in light burn and burn off center in reality. Even if I use the move buttons to put the laser on any designated portion of the design in lightburn it still moves to that part of the design on the work surface even though it’s centered in light burn and not in reality.

I’m now beginning to think there was an update or something in either lightburn or xtool that is causing this with some machines. Another user posted on a Facebook group today a picture of exactly the same thing occurring to them. All of my designs that are centered in light burn are actually burning to the left and high and that’s exactly what this users were doing as well. That seems like too much of an uncanny coincidence.

Let me rephrase. It’s not obvious to me what the root cause is. I understand what you’re indicating and what’s shown in the video. Just not why or what exactly is going on. There’s very likely a consistent and resolvable issue if the behavior were better understood.

It’s unlikely an issue in LightBurn code. I wouldn’t rule out a firmware issue with xTool but this doesn’t feel like a typical xTool firmware issue. This is most likely a workflow, design, or procedural issue based on the type of symptoms but don’t see anything that pinpoints where it might be originating.

Anyway, your call how you want to proceed.

Gotcha, makes sense; I apologize if my reply seemed snarky, I thought you were telling me there wasn’t an issue. It’s very interesting another Xtool user posted the exact same problem today.

I ordered a Devil1 from Geeks at Large today, I’m just taking the whole Xtool brains and stepper motors out of the picture, hopefully problem solved. It does really bother me that I can’t figure it out though.

I hope someone that has experienced it comes along with at least an explanation. I’ve about thrown in the towel with the countless hours I’ve spent "experimenting " for solutions.