Workspace not matching engraver workarea, laser diode not cutting at full power

To ensure your LightBurn workspace matches the physical size of your laser, click the ‘Spanner/Screwdriver’ icon top-center of the main screen to reveal the ‘Device Settings’ window where you can enter the size values. (Screenshot is an example only, enter your correct data)

You can control the ‘Units’ of measure used in LightBurn to help with this. Click the ‘Gears’ icon top-center of the main screen to reveal the LightBurn ‘Settings’ window.

1 Like

Thank you
I’ve been able to change the units into millimetres.

But I Still can’t match the actual size of the grid in lightburn to my workarea even if input the right work area size, and I increase my job size it doesn’t correlate to the actual size of my laser cutter…its almost as if things are shifted

As long as you don’t home the laser, this will happen because it has no idea where it is.

If you don’t have homing switches, it means that the zero point of the machine is random, in fact, wherever you have the head when you power the machine will be zero. To set the zero point properly, either power up the machine with the head at the front-left, or jog there and enter this command:

G92 X0 Y0

The above tells the controller “where you are right now is X0 Y0”.

If you use this command, you’ll also need to set $10=0 in your console, as this tells the laser to report its position relative to that new origin, instead of relative to where it was powered up. That value is ‘sticky’ and will persist after you shut it off, so you only need to set it once, unless something else changes it.

1 Like

I tried that but I still was getting the same problem, However prior to that this what I got on the screen.

I don’t know if this could be the problem.

Tried what, exactly? This will go smoother if you tell us exactly what you did and what the result was in as much detail as possible. Saying, " I did that…" allows for a lot of potential misinterpretation.

error:5 = Homing cycle is not enabled via settings.

Here are listing of what all settings mean:

You have not provided much in your forum profile about the system you have and how it is configured. Please provide more so we can help.

My apologies.

This was what I tried
G92 X0 Y0
And entered this
$10=0 in the console

It did not work.

Thank you :pray:

Please type $$ into the console and hit enter/return. Then copy and paste the entire contents of what gets spit back here for review.

Can we assume you do not have limit switches for this setup?

But I have already add these details in my first post.
Here they are again
The current firmware to my knowledge is

Previously I was using these

Im currently running windows 10 Pro
Im running lightburn 0.9.11 version.

This is the controller board of the engraver.
2 Axis Stepper Motor Control Board Driver For DIY Laser Engraver Benbox.

This is the laser module I’m currently using.
15W Laser Head Engraving Module TTL 450nm Blu-ray Wood Marking Cutting Tool.

I don’t have limit switches.

$0=10 $1=255 $2=0 $3=0 $4=0 $5=0 $6=0 $10=0 $11=0.010 $12=0.002 $13=0 $20=0 $21=0 $22=0 $23=0 $24=25.000 $25=500.000 $26=250 $27=1.000 $30=1000 $31=0 $32=1 $100=250.000 $101=250.000 $102=250.000 $110=500.000 $111=500.000 $112=500.000 $120=10.000 $121=10.000 $122=10.000 $130=200.000 $131=200.000 $132=200.000 ok Thank you 🙏

You changed things, right? So I asked for the most recent view into your firmware settings. Example, your old $10=1, now after your change, $10=0. We can go back and forth as to why I am asking for the information so you will understand, but that will not change what I need to confirm as I try to help you.

Is it safe to assume you entered that into the LightBurn console? Where did you have the laser when you enter this? Did you do this before or after changing the $10 setting in your firmware?

I do apologize I’m sure this is causing the both of us an equal amount of stress I’ll try to be as crystal clear as possible.

Yes I keyed in the G92 X0 Y0 in the lightburn console. I had the laser at the bottom right corner then I have to jog it to the bottom left hand corner of my machine.
I did it after changing keying in G92 X0 Y0 and $10. Then I tried to frame a job which made to the motor drivers overstepping again.

Turn off your laser.

Set ‘Origin’ in the ‘Devices Setting’ found by selecting the ‘Spanner/Screwdriver’ icon near the top-center of the main LightBurn screen. This is the machine origin, not the origin of a job which can also be controlled.

Move the head of your laser system to the front left corner.

Power laser system on.

Please tell us what happens when you do this.

So I switched off the board connected to the ttl laser. But the USB was still plugged in.

the origin was already set to bottom left corner.
But I noticed the my x n y above the air assist in the device setting were set to x=48 y=48 so I changed them to zero.

Powered laser system on.

Nothing happened at first but when I tried to frame again it went overstepping. However later…I tried jogging it back to the bottom left corner it stopped half way and wouldn’t respond…

It couldn’t move close to the left hand side of the frame.

Sorry, but I have no idea what you are saying here. Can you reword this, please?

I feel the need to identify that I am not trying to make this harder than it need be. I am trying to figure out what your system is doing and help explain what you need to change to get it to work. You took additional steps and made changes while I was trying to walk through a process to determine what is happening as I am not there to observe with my own eyes. Not sure where we are at this point.

Do you have any other software that came with this system? Have you tried to get things working correctly with that software?

I am going to offer this post as a suggested approach to help you get your system set properly. It is for a different system but these differences should not cause concern.

Read this, follow these steps and we can go from there.

I am sorry was sleepy when I wrote that.
I’ve fellowed your instructions again.

Switched off the laser.
( note the USB plug is still plugged into the pc)
Went to the origin and set it to bottom left.

Powered it back on

What happened?

I tried jogging the laser to the rest of the frame but it seems that Im limited to the edge of where I tried to manually home the laser of the frame. It only moves along the X axis but not the Y.

Initially I was using the benbox laser software but that turned out to be buggy. The only purpose was for changing the firmware.

I’ve read and fellowed the steps from the link you send.

Ready for the next step

Thank you.

You would need to unplug the USB too. It still powers the controller.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.