Workspace origin vs machine home and LB laser power questions

How can I offset my workspace origin from my mechanical home (using limit switches)? To clarify (I hope) when my laser head is homed it needs to move a bit in both axis’ to get to the work bed. If I try to use absolute coordinates, the laser starts the job from the mechanical home position not the bed origin. I’ve compensated by using current position or user origin, but I would like to be able to use absolute coordinates as well.

Second question: The maximum current on my CO2 laser tube occurs at about LightBurn’s 72%. Is there any way to “calibrate” LB so that my max current occurs at 100% instead of 72%? Thanks in advance for your help!

If 0, 0 is in the corner that’s absolute 0 and you can’t change that.

If you set to absolute coordinates. The ‘green square’ will indicate 0, 0. Drag the design to where you want it to be on the ‘table’.

Screenshot from 2022-05-07 12-02-39

I use this all the time for anything in one of my jigs that holds parts.

If your system is configured properly this should be pretty easily done…

Make sense?

:smile_cat:

Move the switches.

I think it makes sense. I believe that what you’re telling me is that I need to offset my drawing on the LB workspace by the same amount that the laser head, when homed, is offset from the physical laser bed. I’ve done that and it works, I was just hoping that LB could do that for me. I wonder if putting a camera on my system would solve my problem? Thanks again for the help.

Much, much easier said than done. But thanks for the suggestion! I may look into fabricating some custom switch mounts to make moving the switches possible.

Let me ask something that may help clarify…

When the machine is at it’s home position, is that outside the ‘working area’ of your laser?


There is a ‘home offset’ on each axes with the Ruida controller. Might look here and see if it’s applicable to your dsp. I’ve never used it, so…

Good luck

:smile_cat:

Yes, my home position is outside the “working area”. Thanks for pointing out the Home offset settings. My dsp is a Ruida, so I’ll play with those settings to see what they do. It does sound promising. Thank you very much for the info!