Would Like To Use Lightburn

I purchased a laser engraver for my wife. It came with Benbox.

It shows Nano everywhere in Benbox.
Can anyone point me in a easy direction to upgrade / change the firmware on the board so that I can run Grbl… Lightburn doesn’t detect or see the unit. T2Laser does, but Lightburn just looks so much sexier…

I will try to get a picture of the board…
It has one button on it for weak/off mode.
Lot of chinese on it.

Board shows…

I believe this can’t be flashed different if I have read correctly as it doesn’t have a FTDI…

The listing seems pretty clear:

It does look like an Arduino Nano with a couple stepstick motor drivers on it, but it might not use the same pin connections as GRBL.

In a ODD occurence… I was toying around with manual device install… found it and can control everything except the laser by using one of the GRBL… It moves, and everything… just doesn’t fire the laser. Went back over to Benbox and everything including laser goes.

Which version of GRBL? Did you change your GRBL settings appropriately? You can type $$ in the LB console, and it’ll spit out some info. Paste it here if you can.

Not too odd - these systems often use modified versions of GRBL, or use it as a base to build their own variations of firmware. I have no idea why they break compatibility - you’d think letting people use ANY software would make their hardware more attractive.

If you can figure out which commands they use to turn the laser off & on, there might be a profile in LightBurn that would work, but I can’t promise anything.

Tried to figure it out… T2 works perfect without changing anything… I wish I could get Lightburn to work.

Use T2 to draw a simple rectangle and save the GCode it generates for it. There might be a difference in how the GCode is produced.

You have provided very little detail other than “I tried and it didn’t work”. What did you try? What settings did you use? How is the board configured in T2? If you can provide more detail we can likely help.

Here are pictures of the board.
I also included a picture showing what the unit was flashed with based on many instructions…


I’m sorry, but that doesn’t help me. If you can do what I requested above, that will help.

quick question… can i just take this junk board out and put in a eleksmaker mana board in???
connecters match… mine is 12volt.

I don’t know - I’m not familiar with that board or the wiring. You’d have to ask the seller.

OK… I was toying with T2… I decided to roll the dice on the menu option for firmware… I let it do the default GRBL… It works… Only thing is that left is right and right is left…

Go to Edit > Device Settings and move the origin point to the other side from where it is now:


(That one is mine - yours might not be the same. Just move it left to right, opposite where it is now)

Got it… Thanks.

For the record… what you have is, at the very least, a clone of the EleksMaker Mana board. I have a couple of the same in my collection.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.