Wrong cutting position

Hello, I have a CNC 4060 80W Ruida 6445G Made in China. I have a big problem when I try to cut a drawing with several elements. Some elements of the drawing are cut elsewhere. All these cut pieces were destroyed. If the drawing consists only of outline, it is cut well, if it has interior designs they are cut incorrectly. I have the impression that after erroneous cutting, the cutting position recovers, but the piece is already destroyed. I tried with a cutting speed less than 10mm/s, but the problem is repeated. The same problem was repeated in another drawing with cut and engraving inside, some engraved elements were made elsewhere. On the display controller, the cropped image looks normal, without errors. I remember that I did not have this problem with the machine from the beginning, I have only owned it for 2 months. I admit that I made small changes to the settings. Please help me with tips. If there is another discussion on the same topic, please let me know. I am attaching some pictures to understand my problem, which is quite serious. I hope it’s not something serious. Thank you in advance.

That looks like it’s losing position in between cuts.
Ruida has a setting called “idle speed” which is how fast the machine moves between cuts.
If you go in to Edit > Machine Settings you can change both the idle speed and idle acceleration. Too much of either can cause the sort of out of place cuts you have.

Thanks Hank, I also thought about this option and changed these values, but nothing concrete. I will try to lower these values ​​again. I have done many tests and it is curious that these erroneous cuts are repeated every time in the same places, with different speed settings (this means that the steps of the engines are not lost). I tried to change the order of the inner cuts, the result was that the errors changed elsewhere. I got good results with normal speed and acceleration (unchanged) when I opted for ‘Optimization Settings / Hide Backlash’. In this case the inner cuts are made randomly and not in order, there is a disadvantage, the cutting time is longer because there are larger displacements between cuts. So in this case I got good results, but I’m not satisfied, I don’t understand exactly what the cause is. I will try again to reduce the acceleration. I mention that this drawing is small in size and those cutouts are very small, but I don’t think that’s the cause. I’ll keep you posted on the results. I’m still waiting for advice.

If ‘Hide Backlash’ helps, check that you don’t have anything loose in the machine, like a stepper gear screw that has loosened, loose belt, or something like that.

If it had a problem reported by you, why is this error repeated every time and in the same places? I think that if it were a mechanical problem, this error would occur in different places. After this error occurs, it recovers and performs cuts in their place, tomorrow I will do some more tests to see if this cutting error is the last process in that drawing. Then moves on to another drawing that he cuts well. Only the drawings with interior cuts create these problems for me. I have other drawings with interior cuts, but much simpler, they are well cut.

I did a few more tests, but I couldn’t find the cause. I noticed that if I twist the image a few degrees, the error moves to other elements. Usually towards the end, after losing the position (about 0.5-0.8mm) follows the erroneous cutting or engraving on the following elements. I also changed the settings, I reduced the acceleration, the problem remains. I don’t think it’s a mechanical problem, belt, motors, etc. because this error is repeated exactly at the same elements in the image. I mention that the simple geometric figures (circle, square) are cut perfectly. If anyone wants to do a test with this drawing, I would be curious about the result. What else can I do?

Proba.lbrn (119.7 KB)

I cut 4 from a sheet of paper and don’t see a problem.
80w red&black with Ruida 6442 controller.

You’ve totally got a problem with the machine losing position when moving between cuts.
What is your idle acceleration please?


You are absolutely right, he loses his position and every time in the same place at the same drawing. I also made a short video where he loses his position, after this moment all the cuts are deflected to the left. I’m not good at settings and Ruida, I post pictures with them and you tell me what to do.
I couldn’t upload the video, but it can be seen in the first image where it loses its position.
Thanks Hank for your effort.

I converted the file from SVG to Ai with LightBurn software, so that it can be recognized by RDWorksV8. With this software the engraving came out perfectly. Then I used the same Ai file with LightBurn software, again execution errors. I repeated with RDWorksV8 a second time and it came out perfectly. What is the conclusion? Why? I really like LightBurn software and I would like to continue using it, but not in these conditions. I would like an explanation from the software developers and fix this problem. I am willing to do whatever test is required to solve this problem. Until then, I’m switching to RDWorks. I did this test at the proposal of the machine manufacturer and he was right. Thanks to everyone who tried to help me and especially to Hank who got involved.

Does anyone have any advice? I did many tests and the results are the same.

Try this:

In LightBurn, click “Devices”, then double click your controller, click “Next”, then pick “Packet/USB”. Click next until finished.

See if that improves things.

Also, with that AI file, save an RD file from RDWorks and one from LightBurn. Get the settings and positions as close as you can, and email them both to support. I can inspect the contents to see if there are differences.

I understand, I’ll try later when I get home.
I mention that today I tried from another laptop and the exact same problem is repeated, at one point it loses its position and moves more to the left, from that point all the cuts or engravings are moved to the left by about 1mm.
As can be seen in the images and the outline is shifted to the left, it is the last execution in the drawing.

I came with bad news. I did exactly as you said, no change. Then I deleted Device from the list then added again with Packet / USB and Serial / USB. I tried all the options. The photo shows error changes when I change the settings in Optimization Settings because the burn order changes. I’m sending the two files you requested. I hope to solve this problem because it is already stressing me out.
Neither in Figure 3 is not all perfect. The inner border is moved to the right and the outer border to the left.

Proba.lbrn (119.7 KB)
Admin does not let me upload the .rld file because it is a format unrecognized by the platform. How do I proceed?

I don’t want the RLD file, I want the output when you click ‘Save to UFile’ in RDWorks, and ‘Save RD File’ in LightBurn. Email both RD files to support@lightburnsoftware and include a link to this thread.

Hi, I have the same problem with both cut and fills and am trying to identify the problem, as you are.
My OS is Windows 10.
Situation to date, the issue does not happen often but when it does the error can be repeated simply by running the cuts from the start button in Lightburn, if I then restart the PC the problem may not re-occur but if it does it may not be exactly the same as before but can be repeated by re-running as above.
Now here is where it gets interesting, my machine has a Ruida controller and the display actually shows the the error ie misplaced cuts. The machine is doing what it is instructed, at least with a cut as an fill does retain display the cut path.
If I send a file to the machine and run the file from the control panel, the error do not occur.
I’ve already tried altering the USB settings and dialling the acceleration way back and this has had no effect.
Further, this had only appeared since I installed 9.20. It’s not the laser and I have swapped out all the USB gear between the PC and laser ( i have a powered hub in the machine to couple the laser and camera so I can connect on a single, high quality short lead to the PC, USB cables are all as short as possible) and tried to a single lead.

Any help would be appreciated as I don’t want to have to run jobs from the machine and do not want to use RDWorks, would be like reverting to the stone age after Lightburn

Regards Andrew, Wakefield England

I talked to OZ by e-mail and tried many options proposed by him, but none gave a satisfactory result. Already, I started learning RDWorks software because I don’t want to ruin material anymore. I like LightBurn, it’s friendlier, but my destiny is to continue with RDWorks. You can do a simple test, place a piece of wood, give “Pulse” for marking Origin, perform engraving with 5% power (in this case the laser will not open), then after finishing the work will return at Origin, give “Pulse” again for marking. Surprisingly, the origin moves to the left and up by about 1-2 mm. During the work it loses its position, more precisely at a passage between the cuts. With RDWorks the same file works perfectly. These are more complex files with internal cuts. Any advice would be useful for all those who have the same problem. I use Ruida 6445 and Windows 10. I mention that I tried another laptop with Windows 7 Ultimate, no improvement. If I manage to solve this problem, I will write here.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.