Wrong position after homing

Hello,

i have a little problem with the korrect homing of my Laser.
After the homing process Lightburn shows me that my current position is X-1998 and Y-1998 how can i fix this?

Thank you in advance for your help

You likely have a workspace offset programmed. G92 X0 Y0 will set the current position to be zero, or G10 L2 P1 X0 Y0 will set the offset to be zero, regardless of where the current position is. Typing $# and pressing enter will display the current offsets.

THX for your quick answer.

The result of $# is:

[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok

But the result is still the same after i use the G10 L2 P1 X0 Y0 command.

G92 X0 Y0 works but why it doesn’t work automatically?

I’m honestly not sure - it depends on which version of GRBL you have, how it’s configured, where your switches are, and so on.

OK i tried to make a Macro.

$H
G92 X0 Y0
But after the homing is finished the position is still -1998 until i use the command manually.
Is my Macro correct or have i made somethingwrong?

PS: I use GRBL 1.1f and my switches are in the front andleft side.

I would suggest reading through this to make sure you understand how it’s supposed to work, what settings can be changed through the console, and what settings have to be compiled in:

I already have fixed some problems i had with my laser and the grbl firmware and if there is no other way than to use the G92 command thats fine.

But my question is why is my macro not working?
Must i use a pause command after the $H or is ist impossible to make a macro like mine?

I would have to investigate to understand why that didn’t work. It’s possible that the macro is “streamed” instead of sent one line at a time, and your $H command isn’t going to be buffered and queued for execution like the G command is. It could be GRBL itself, or it could be how we’re sending it.

Ok, this is a slightly tricky one - We only wait for 1 second for commands to complete if they are non-buffered commands. $ commands are special, and don’t get “planned” like normal GCode commands, so when we see one of those in the macro, LightBurn sends one command at a time, and waits for it to complete. If it doesn’t come back within a second, it gives up. Since homing takes so much longer, it’s a bit odd. We don’t want to lock out the UI completely if something fails, so we set a “reasonable” timeout.

You can just enable the ‘home on startup’ behavior, and then all you’d need to do is hit the macro with the G92 command when it completed. I’ll see if there’s a different way I can do this without breaking things.

Ok, it’s fixed and will be in the next release.

We recently added the ability to use “ping pong” sending in the GCode thread sender, instead of fire-hosing the GCode to the controller. For macros that contain immediate commands like $H, I just flip the switch to tell it to use ping-pong sending for this one job, then switch it back to whatever the user setting was when I started. It works.

1 Like

Big THX for the Help :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.