Wrong travel direction after limit switch Assembly

Hello, everybody,
I have a problem with my ELEKSMAKER A3 laser. I bought and installed the Eleksmaker Extraboard for the connection of the limit switches.

Additionally I installed the GRBL firmware 1.1h.

When I now press HOME, both axes move in the right direction until they reach their limit switches. Then drive a few more millimetres forward and stop there (zero point).

If I then start from this “home” position with a laser job, they do not drive forward into the working area, but back again into their limit switches.

I have tried everything with the parameters $2 and $3, but this doesn’t change anything. The axes actually drive “correctly”, because the limit switches are approached correctly when searching for the home point.

Only when I want to start a laser job do the movements seem to be inverted.

Does anyone have a clever idea? I am using Lightburn version 0.9.07.


Starting stream
On or near line 4:
Stream completed in 0:00
[MSG:Reset to continue]

Hi Joe, I have a home build based on the Mana controller and the s/w works ok with it, so suggest this is an origin or work space problem. I assume your home switches are in the bottom left corner? If so, on the device settings page (spanner icon) is the radio button in the lower left corner? If you home it and drive the axis with the move buttons does the axis move correctly into the work area or are they also backwards?



The Y axis limit switch is in the upper left corner, the X axis limit switch is in the upper right corner.

So in Lightburn under Basic Settings I marked my Origin point in the upper right corner.

o X
o o

Moving the axice by button, thy also go backwards.

I was about to tell you about $3 settings, but I see you have tried those. But you also have a $23 setting that changes the homing direction. I haven’t tried it but perhaps that is throwing the diagnostics? the homing direction can be correct even if the running direction is wrong. Have you tried $3=3?
You have an alarm 2 soft limit at line 4, have you looked to see what the Gcode is actually sending?

Could be it needs a workspace offset:
see forum post:

Depending on the version of GRBL you’re using, you might need to set a workspace offset. LightBurn only works with positive workspace. Read here for more details: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md

You may find this of some use. This is from the GRBL Config.h file that gets compiled at the time GRBL is flashed on to the chip that runs everything, the Atmel chip on the main controller or Arduino Nano board on some controllers, or directly on to an Arduino board if you use that. Lines 126 to 129 may be of interest. If you wanted to change anything in the config.h file you would edit it, save it and then recompile GRBL and upload it to the chip. To do that you would need to download GRBL and use something like the Arduino IDE programmer.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.