Wyze cam resolution

I’ve managed to get my Wyze camera setup with rtsp to work as a Lightburn camera. But I can’t seem to get great resolution with it. The camera is 1920 x 1080, but when used with Lightburn I’m only getting 640x480. Other apps that use RTSP (VLC, Skype, etc) show the full resolution.

Any ideas on how to get better resolution in Lightburn?

I’m also using a Wyze Camera Setup, this was my solution that’s worked best for me so far:

  1. Install OBS (https://obsproject.com/download)
  2. Install OBS Virtualcam Plugin (https://obsproject.com/forum/resources/obs-virtualcam.949/)
  3. Open OBS and add media source with input:

rtsp://<username>:<password>@<ipaddress>/live

  1. In OBS set output resolution by going into File->Settings->Video-> Output Resolution -> 1920x1080
  2. In OBS click Tools -> Virtual Cam, check AutoStart
  3. Restart OBS
  4. Open Lightburn -> Settings -> Capture System to default
  5. Run Lighburn camera configuration with OBS-Camera selected

Couple things to note are:
1)The Virtual Camera plugin is planned to be part of the default OBS install starting with OBS v26 so in the future step 2 won’t be necessary
2) You will need to start OBS anytime you want to use the camera with Lightburn
3) I believe the plugin is windows only

If you have any trouble with my instructions or questions I’d be happy to answer what I can

I followed your instructions. Should I be seeing video in the video window of OBS once I restart in step 6? When I open the Windows 10 Camera app, the camera shows up in the list of available cameras, but there is no display. Same thing when I try it in lightburn - blank screen.

I think I may be having trouble with step 3 - I am not familiar with OBS. I selected the + sign under Sources, then selected “Media Source” then typed in my rtsp address. What should be checked in the configuration screen for the source? It currently has the “Local File” box checked but has no filename. And what should the rest of the check boxes be set to?

Yea you should be seeing video from the wyze camera in obs, i’ll detail the OBS section a bit more hopefully it helps

1)Select the plus under sources
2)Select Media Source
3)Create New source
4)Uncheck Local File
5)New Input field should appear
6)In the input field you should type whatever the rtsp address for vlc was
i.e. rtsp://<username>:<password>@<ipaddress>/live
7) You should now see the Wyze feed in OBS

Yeah, that did it. I was typing the URL in as the media source name rather than in the input field on the next screen.

Thanks!

1 Like