X alignment issues

Using a 60W Chinese laser with a Ruida controller that has functioned well since I got it. Using a chuck rotary attachment that has also worked quite well. Upgraded to the new version of Lightburn yesterday.

Now I am having a serious problem with X axis errors in alignment. Parts of the image etch offset to other parts of the image along the x axis. The offset appears to be completely random. I did a test on a clear glass tube and it came out perfect. Went back to the blank I wanted to etch and the offset problem persisted. One photo shows the binary numbers in line like they are supposed to be. The other two photos show the offset problem. For the life of me I cannot imagine what could cause this issue along the X axis. I have had this laser for about three months and have not seen this problem before.

How are you connected to your Ruida controller (USB, Ethernet, or any Wifi)? How are you running the job (using the Send command or Start command)?

(By “using any Wifi” I mean, is there any Wifi in use directly between your computer running LightBurn and the Controller)

USB. Using the send and start commands like I always do.

You mean you have tried both ways (you are using Send or Start) and seeing the same result independent of the method of running the job?

Is the symptom random or is it consistent with every job? Does the area of shifted engraving stay consistent?

I was not aware that I could just start without sending the job first. So I always send it and then press start. The offset error appears to be completely random and is never the same twice.

Just reinstalled 9.2.0 and ran the file and no errors! I is possible that there is a bug in 9.2.1?

And I prefer to send first before I start the job so I can check the framing first.

Test number two came out perfect. It’s a bug in 9.21

I don’t know if this is helpful or not, but another thing I noticed was that my default speed setting in 9.20 was 200mm/sec. When I imported machine settings in 9.21 that setting said 199.99. Upon re-installing 9.20 the setting was 200 again.

The new release, 9.22, appears to have resolved the bug. Great work guys!

Argh! I spoke too soon. The glitch just showed up again. Switching back to 9.21.

If you are willing, please have a look at this post and let us know if this resolves the issue.