X and y 10,000mm Riuda controller rotary issue

Hello LB community, hope everyone’s doing well and we’re staying warm up here in Minnesota -9F -33wc!

My question about my FL 1390 with the Riuda controller surrounds my rotary and inconsistencies with being able to successfully run it each time I try. It turns into an hour long of problem-solving with moving my Y axis halfway between the distance of my bed which is a 40 inch bed. It seems to have a mind of its own as to when it wants to work…

I believe I’ve done all the correct measures such as setting up my object diameter and steps per rotation including job origin and setting my origin before hitting GO after pulling up the file that I sent from LB…

I’m getting a constant frame slop issue trying every mm shift from 100-888 but then every once in a while the machine prompts to turn it off and back on again. When that happens “and I don’t know why”, I noticed my X and Y goes from zero up to 10,000 after that restart, I can send my job and there’s absolutely no issue with engraving on the rotary. I will also note when I take the mm up to 888 on the Y before overriding the frame slop, it starts and gets half way through (graphic is only 1.5 inches wide) and promts a “no enough exstended space”.

So finally my question is how do I set my machine to be at the 10,000 Y and 10,000 X and Y settings so that I don’t burn an hour or two problem-solving every time I use my rotary machine?

Does the axis docking or backlash have anything to do with its settings?

It would be a small victory to be able to reduce my rotary set up time to 5 min max and that should be realistic.

Any help would be great :+1:t3:

I just saw 10,000mm x 10,000mm as a start position come up on an internal channel.
The Ruida enters this mode when the X & Y homing switches aren’t available.

The on-off sequence of the engraver is part of the rotary status setting.
That’s in the Note at the end of this doc.

Which Ruida controller do you have (model number) and are you unplugging an axis to run the rotary?

1 Like

Is this new or has it always been an issue?

On my Ruida, if I boot/reset it and press it will halt the home process and set x and y at 30,000.

How this works is really kind of dependent on your procedure of operation…

The Ruida is kind of dumb in many ways, but if it tells you there is a slop error I’d bet money on it being correct and you should not attempt to run it…

All this indicates something isn’t configured properly as it shouldn’t take any time at all to change from normal table to rotary. I can consistently do it in a few minutes.

It may be the procedure you’re using…

Thanks for the feedback, I am curious how one might configure this to correct the problem? Also I wonder how my procedure might be Messing up the set up. Here’s my procedure:

Plug in the y controller aka pi burner while machine is off. Next align the x over cup. Thirdly turn on machine. Next it should home which it does. Then I “send” my graphic after setting up rotary Steps per rotation and diameter etc. next set origin and scroll my y down on the controller up to about 250mm (I’ve tried all the increments by the hundreds when I get frame slip error). If this doesn’t work I shut the machine off and repeat until it works. The night I got it to work is when I posted this thread for help. I just happen to scroll the Y to 160mm and it worked. As of now does this seems is this the only solution?


I’m not by machine atm but it’s the Riuda 6055 if that sounds right? Could you describe internal channel? Lastly I believe these

prompt is what gets it to work sometimes in the pic.

You need to explain how it homes with the rotary in place of the Y axes.

Without limit switches and no other modifications to disable one of the axes from homing, it should fail the home sequence.

I don’t remember you stating what kind of rotary you have but you keep referencing the diameter, is this a chuck?

Depending on how you have ‘Start from’ and ‘Job origin’ set…

We need to make sure we understand each other and the main problem here appears to be the coordinate system…

If the dashed lines that cross about center is the ‘User Origin’, set on the machines console, then a single rectangle will direct the machine to one of four areas, relative to the ‘User Origin’. There are 5 other positions for Job Origin.

Please excuse my far from perfect drawing…

  1. how is the rotary ‘homing’?
    a. is this the root of the issue?
  2. roller or chuck type?
  3. after ‘homing’ what are the x and y values in the machines console?
  4. settings your start from and job origin
  5. understand how the Start from and Job Origin is working?

Good luck…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.