X and Y axis move 15x farther then specified

Currently axises are moving ~15X the distance specified.

Image A shows a 2mm square in Lightburn.
Image B shows the 32mm hole that lightburn cut from that square.
When I click start I get a warning that the cut may be out of bounds even if the box is centered in the work area.
I have tried to swap out drivers and cnc shield. Reuploaded grbl 1.1h which did not solve the problem,
The machine settings are the default GRBL settings which worked for me before.
Anybody have any suggestions?

Have you calibrated your axes? $100, $101 define the steps/mm for X and Y respectively.

However, if what you’re saying is true and you’re off by 15x then that would put you at 5.33 vs the current 80 that you have for those values. That’s unusually low. This will be affected by multiple factors including step angle of your motor, microstepping, belt pitch, pulley tooth count, etc.

Check out this LightBurn page for more information:
Steps / mm - LightBurn Software Documentation

You may want to just confirm that the final calculated value is in accordance with your equipment. I say this only because of how small those values are. That won’t give you a whole lot of resolution in movement.

LightBurn also offers an axis calibration feature in Edit->Machine Settings->Calibrate Axis.

if you are running the current version of Lightburn go to EDIT, Device Setting and you should see the option “Enable Out of Bounds Warning” if it is green click on it to turn off and you should be good to bo.

Thank you for your reply. The 80s/mm setting was working for me over a year so I am sure that is the correct setting. Something else changed to affect the travel distance of the axises. I have not figured out what that could be. I will use the stepper calculator once I dissasemble the machine to count the gears
I will keep you updated

Do you possibly have Rotary enabled?

How can I chedk that?

3 ways:

  1. Laser Tools->Rotary Setup
  2. toolbar rotary icon - will show a green dot when enabled.
  3. Enabled Mode: Rotary at bottom right of screen.

Thank you for your help. Pointing me to the steps/mm calculator which led me to setting the microsteps jumpers
With DRV8825 drivers installed set to 1/32 at 80s/mm did the trick.

Thanks again
Richard McClelland

Glad you got it. Figured it was the microstepping setting since you were off by about 16x. How did the drivers get messed up if you had made no change prior?

I tried to clean up the wiring to the stepper motors. My memory is not so good these days and I think I swapped the cnc shield and never set th jumpers on the new shield.

Ah. K. So there’s a likely explanation that something might have changed. Better than this being completely unexplainable where something else might be lurking around the corner.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.