X-axis drifting after engraving multiples

I’ve had a look at similar posts and they don’t seem to fix my issue. Basically what’s happening is when I engrave multiple parts and I’d like to run the program again the x-axis will have drifted significantly. I have run a test engraving the letter “i” multiple times in columns from left to right. By the time it has finished the x-axis is off by about 3.5mm.

I’ve checked the belts. I’ve tightened everything. I’ve changed speeds and acceleration. I’ve turned off PWR rising. I’ve changed backlash. I’ve tried axis calibration.

If I reset the machine and run it again it will engrave in line over the last pass so it drifts consistently. The issue I have is if I want to engrave and then cut out parts the cut will be 3.5mm to the left. I can’t even reset the machine between engraving and cutting as the drift will not occur at the same rate when cutting. My only fix for the time being is to engrave and cut each item before moving onto the next but I’d like to find a solution to the drifting.

I’m at my wits end here. If anybody can offer any help or advice it would be greatly appreciated.

Niall.

QueenCNC QN-1390
60W - 1250x850
RDLC633XG/634XG
RDLC-V .6.00.61
HMI-V1.00.55


I’ve tried another test. I have a 750mm vertical line set to cut and an 750mm vertical line (0.05mm wide box) set to engrave. They are both on layered on top of each other so should start and end at the same points.

Here are the results:
Start:

Finish:

So it has drifted left about a milimeter.

Some recent posts suggest the screws holding the entire laser head on the gantry can work loose (*), so that the head either shifts or tilts as a result of X axis motions. A very slight motion can produce dramatic shifts in the spot position, so check carefully.

It’s also possible for the focus lens within the head to work loose and shift. Worst case: it’s broken!

Basically, grab the head and wiggle to feel whether it can shift in any direction, then take it apart to make sure its innards remain firmly secured.

If that doesn’t reveal anything, verify the screws attaching the belt to the head don’t allow any motion. That’s independent of the belt tension, but since you’ve already crawled around in there, you know what to look for.

(*) Or arrive pre-stripped from the seller, which is not your situation.

I am not sure what is X or Y, or even if the end location is too far or too short. Bot no matter.

This is where you should work. Home the machine. On the inaccurate axis of travel, burn a straight line of known distance (X=1200mm or Y=800mm). Then measure that line. If it does not match what you programmed, the Steps Per Revolution needs to be adjusted.

I do not know if you can adjust this for your machine. I also see a Backlash adjustment for your controller. If you reverse direction and return the same distance, Backlash will show up as a loss of distance in the return path.

P.S. @ednisley beat me to the reply. He is Master, I am the Padawan. Follow his advice thoroughly before using my paragraph.

Thanks Ed,

I’ve given everything you mentioned an extra tightening, although it was all pretty snug anyway, and I’m running another test now. I’ll let you know in about 15 minutes if it has made any difference.

Update:
@ednisley

No Change :cry:

Hi Mikey,

I’ve already checked the calibration by drawing a rectangle just under the full size of the bed and checking the measurements. They were pretty bang on. I think I had 1150mm measuring as possibly 1149.9mm but it’s tricky to get an accurate measurement. I made adjustments to see if that 0.1mm would make a difference and the overall width of the engraved area reduced but the drift stayed the same on the second pass

Then that leaves Ed’s floppy head theory.

As a side note, I burned a 100mm circle in the front left and right rear areas. The front circle ends missed by 2mm. The right rear circle was perfect. Loose set screws on the Xaxis should have made both fail, right? The story here is take nothing for granted. “It must be okay” is not a valid troubleshooting step. :roll_eyes:

I hope for Ed’s sake this doesn’t catch on. :joy:

I think I’ll need to spend more time making small adjustments and testing the results. I was hoping it would be something simple I had overlooked.

I hope you knew I meant floppy LASER head, right? :joy:

I knew what you meant!

I have a 3 day job to run cutting 1.5mm ply. The drift doesn’t seem to be noticeable when cutting objects. Hopefully I can find some time soon to get back to running tests.

I ordered new bearings for my x-axis. There seems to be a bit of wobble in one of the bearings when you loosen off all the belts. It could be the culprit so I need to rule it out.

I’ll post my results when next week.

I’ve replaced a bearing on the X axis that I suspected was worn (The laser isn’t a year old) but it doesn’t seem to have solved the drift issue. I’ve basically stripped the machine and put it back together again and its still drifting left over time when engraving. Not sure what else to do.

Can anyone from Lightburn shed any light on this matter? I’ve tried everything I can think of to try and resolve it and nothing seems to make any difference.

I am having a simular issue and started with the Seinci forums hopiong someone had and fixed this issue. The right side of this should be straight. Getting massive drift on the x axis. Was thinking this was bad stepper motor but its very repoeatable.
Processes tried.

*Running direct from Light burn. result drift

*Console $30=1000 and $32=1 same tool path drift.
*Concole $30= 30000 and $32=0 same path drift.

Hope the image loads.