X Axis flipped when burning

Hello so I had been using lightburn for almost a year to basic engraving/cutter on my eleskmaker a3 pro when I decided to put limit switches on it hoping to add a camera in the near future for it. Well since I have done that my images come out flipped on the X axis and I am not sure if I am missing a setting I might have changed or something?

Chris

It’s possible that you changed the direction pin settings - that would be $3:
https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#3--direction-port-invert-mask

Take whatever number you have there right now and if it’s even, add 1. If it’s odd, subtract 1. That will toggle the X bit and reverse the direction of the X axis.

For example, if the number is currently 5, it’s odd, so subtract one to make it 4, and set it by entering this into the console:

$3=4

(the actual number in your controller will likely be different)

Hi Oz,

That seemed to have worked, not really sure how or what changed it but thank you very much for your help.

Chris