X axis jog buttons inverted

I have a laser running GRBL on a MKS DLC32 board, machine homes to the bottom right corner. I have motion setup so the buttons on the LCD match, Y+ moves it up, X- (left button) goes Negative and moved the carriage left and so on. I connected the machine to lightburn and when I set it up with the bottom right corner for origin, the X axis buttons are inverted- Left goes right and right goes left. The “get position” numbers are correct in regards to left movement being negative and right going positive. When I set the lightburn profile to homes bottom left, the buttons all match up correctly with the left button moving it left and negative, right moves right and positive but then the absolute coordinates option for starting a file wont work. I found another post that talked about the machine settings menu under edit, but I checked that and there is no “vendor” tab with the invert buttons option like it mentioned, I think thats just for the ruida controller. Thoughts?

LightBurn is intended to work in positive coordinates.

You have 2 options:

  1. Configure the machine so that up and left are positive coordinates
  2. Set a work offset so that Origin is bottom-left with positive coordinates going up and right.

Technically you could set this up at the other two corners but makes less sense given your circumstances.

Do you have a preference for which option?

This is where a coordinate system offset fits best in my opinion (option 2 PY mentioned). Move the laser to the bottom-left position using the arrow buttons (be careful to be exact without hitting the frame). Send the command:
G10 L20 P1 X0 Y0
In the console. This sets an workspace offset to that position. Afterward, set $10=0. Then both LightBurn (with origin bottom-left) and the touch display buttons should work.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.